Jump to content
Get SynergyOpen a support ticket

Windows client login focus issue (bug?)


Recommended Posts

My setup is a MacOS 12 (Monterey) server and a Windows 10 client. When the Windows 10 machine has been idle for a while and requires a login I have to do the following:

1. Move the mouse to the client desktop and click to get the password/pin field (expected)

2. The mouse then jumps back to the server desktop and I have to move it to the client again to get the focus on the password field. (not expected)

3. As soon as the password is entered and accepted on the client, the focus goes back to the server and I have to move the mouse to the client desktop again to begin to use it. (not expected)

Is this expected behavior or a bug?

Edited by L.P.
Link to post
Share on other sites
  • L.P. changed the title to Windows client login focus issue (bug?)
  • 2 weeks later...
  • Synergy Team
Daniel Evenson

Hello L.P.,

We recently made some changes to secure input, what version of Synergy are you using (on both client and server)?

There is also an option to "elevate privileges" to always rather than as needed. I think what may be happening is that the service is restarting to provide elevated privileges, and when the service restarts the mouse and keyboard control reverts to the server.

Link to post
Share on other sites
  • Synergy Team
Daniel Evenson

Excellent, glad to hear the issue was resolved.

If you need any further assistance, we are here to help 😀

Link to post
Share on other sites
  • 2 weeks later...

Hi there, Sorry to hijack this thread.

I have also been having this annoying issue.  I run the latest version of Synergy with 1 monitor and two Windows 11 PCs linked to the monitor via a Displayport Bi-Directional switch. Whenever I switch to the second PC I move the mouse to that PC, but momentarily the focus goes back to the main PC. I have to drag it like two times for it to stay on the second PC. 

I'm going to try the elevated privileges trick to see if it fixes it and will report back. 

Link to post
Share on other sites
  • Synergy Team
Daniel Evenson

Hi again Eli 👋,

Let us know if the elevated privileges option helps you. If not, please open a ticket as I would be interested in seeing what is happening in more detail 😀

Link to post
Share on other sites
17 hours ago, Daniel Evenson said:

Hi again Eli 👋,

Let us know if the elevated privileges option helps you. If not, please open a ticket as I would be interested in seeing what is happening in more detail 😀

Unfortunately, it didn't fix the issue for me. The mouse keeps going out of focus and back to the other screen two or three times before I manage it to stick on the desired monitor.

Link to post
Share on other sites
gingerpauls

@EliI had this issue and the elevate privileges worked for me.

Just to be clear, you need to go to (in Synergy app) the Computers Preferences

"This Computer's Name: SomeName (Preferences)"

then navigate to Advanced > Elevate Privileges.

 

If that doesn't work then open a ticket as @Daniel Evenson suggested.

Good luck

Link to post
Share on other sites
42 minutes ago, gingerpauls said:

@EliI had this issue and the elevate privileges worked for me.

Just to be clear, you need to go to (in Synergy app) the Computers Preferences

"This Computer's Name: SomeName (Preferences)"

then navigate to Advanced > Elevate Privileges.

 

If that doesn't work then open a ticket as @Daniel Evenson suggested.

Good luck

Alright, I had done it, but only on the main computer, I have now done it in both places. I'll report back if it works as expected. 

Thanks for your help.

  • Like 1
Link to post
Share on other sites

The problem seems to have been fixed now after I elevated privileges on both computers.

Thank you guys.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...