Jump to content

Hello! 👋

These forums are now archived (read only).

Join us on Discord.

Keyboard not working on Windows clients using Mac as server--just started happening.

Recommended Posts


After working on this over the course of many weeks, as well as wasting money on Sharemouse, (top tip, don't), I was finally able to resolve my issue.  

Secure Input by Apple was absolutely my issue.  Rebooting and them having all my apps and windows re-open was also a big issue.  My solution was to run the Applescript I found here.  This told me what was holding onto my keys and not letting go.  I also closed out every app I had running and started from a fresh desktop.  I also went in and cleaned up my startup items to make sure nothing in there that was old was causing me issues.  

After another reboot it was fixed.    

Related note, Synergy really is the best and most reliable option out there for cross-platform KM.  I have tried all of them over the past week.  Nothing works as seamlessly.

Link to post
Share on other sites
  • 3 months later...
  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

  • Siva


  • ChrisC_1000


  • Danny Parker


  • Tony Trinh


Following the thread from @ColumbusGEEK I did run the script and determined that secure input was on.  Further I simply closed as many apps as I could and presto, the problem was fixed.   I don't know which app is the culprit, but I will keep testing until I find it.  Interesting problem, and I'm sure it's solvable, but I'm running version 1.14.1 (latest stable release at this time), and the problem is still there.  Yes, running same on Mac server and the Windows client.  

Link to post
Share on other sites
  • 1 month later...

Just chipping my experience on this matter;

Set up is a server and one client  🖥💻

On the client the keyboard input stopped working but mouse was fine. Found this thread on the issue.

I ran the following on both my Macs that were in use:

ioreg -l -w 0 | grep SecureInput

From here I could see which machine had SecureInput in use (in my case the server), from there closed down the suggested apps that might be using it, in my case this happened to be the SystemPreferences panel I had left open 👍

So note, that the machine that stops receiving keyboard input isn't necessarily the machine that has SecureInput running 🤦🏼‍♂️

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...