Jump to content

Win32 compiling problems


Recommended Posts

Guys, I think there's something wrong with your compiling instructions for windows. I've created a virtual machine here with Win7 Ultra. I've installed everything listed in dependencies section with the specified versions for each one. This includes VS2010, which I used the Ultimate version (I was lucky to have a license for that). At the end of the build process, it complained that mingw32 was missing. This wasn't in compiling instructions! So I got the current version of it 4.8.1 and got it installed and properly put in PATH. I tried again to compile, and it passed that line of error, but I got stuck into another line: g++ -enable-stdcall-fixup -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-reloc -Wl,-s -mthreads -Wl -Wl,-subsystem,windows -o ..\..\bin\Release\synergy.exe object_script.synergy.Release -L"c:\Qt\2010.02\qt\lib" -lmingw32 -lqtmain tmp\release\Synergy_res.o -L../../ext/bonjour/x64 -ldnssd -lQtGui4 -lQtNetwork4 -lQtCore4 g++: error: unrecognized command line option '-Wl' Makefile.Release:222: recipe for target '..\..\bin\Release\synergy.exe' failed mingw32-make[1]: *** [..\..\bin\Release\synergy.exe] Error 1 mingw32-make[1]: Leaving directory 'C:/synergy-master/src/gui' Makefile:50: recipe for target 'release' failed mingw32-make: *** [release] Error 2 Going back to: C:\synergy-master Error: mingw32-make release failed with error: 2 So I found an option -Wl without comma. I took it off and recompiled that line: g++ -enable-stdcall-fixup -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-reloc -Wl,-s -mthreads I DELETED THIS>>[-Wl] -Wl,-subsystem,windows -o ..\..\bin\Release\synergy.exe object_script.synergy.Release -L"c:\Qt\2010.02\qt\lib" -lmingw32 -lqtmain tmp\release\Synergy_res.o -L../../ext/bonjour/x64 -ldnssd -lQtGui4 -lQtNetwork4 -lQtCore4 It worked. But, final exec is complaining about missing _Z17qt_message_output9QtMsgTypePKc in QtCore4.dll... So what should I do? What I did wrong?
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...