Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

CentOS client doesn't save Synergy server name


Recommended Posts

Hawk McDuck

I'm a long time Synergy user.  At the moment I am using Synergy version 1 on five computers, all 64-bit,

as follows:

CentOS   MacPro2008  MacPro2010  GenericPC  iMac2011 

The iMac2011 is the Synergy v1 server running 1.11.0-stable-b2173efb, and I recently added a CentOS 7 client running 1.11.0-stable-b2173efb. 

When I open the Synergy app on the CentOS client, a dialog box pops up saying "Please fill in a hostname for the synergy client to connect to."  I fill in the IP address of the Synergy server, click Start, and Synergy works well.  If I have to stop Synergy, or reboot or halt the system, the Synergy client on CentOS forgets the Synergy server IP. 

Note that the client window states "Synergy is connected (with TLSv1.2)" and "Manual config mode active, consider using Auto Config instead (Settings)".  However, when I attempt to use Auto Config, I get the same problem with the client not knowing the Synergy server IP.

Please advise.

Link to post
Share on other sites

Couple of things to try. First... can you add an entry on the CentOS client for the Synergy server in /etc/hosts (unless you have a DDNS server or something similar)? It might be a name resolution quirk in CentOS. Second... can you try it without TLS? 

Link to post
Share on other sites
Hawk McDuck

@jmlThanks for your speedy reply.

[stewart@freepbx ~]$ uname -a Linux freepbx.sangoma.local 3.10.0-957.21.3.el7.x86_64 #1 SMP Tue Jun 18 16:35:19 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
[stewart@freepbx ~]$ cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4 freepbx.sangoma.local
::1         localhost localhost.localdomain localhost4 localhost4.localdomain4 freepbx.sangoma.local
#  Added the entry below on 02-20-2020 at the request of jml at Synergy support
172.16.0.180    iMacHeron
[stewart@freepbx ~]$

In a terminal I killed the two synergy PIDs (Synergy was not showing in the GNOME menu bar --a.k.a. System Tray) and when I restarted Synergy it appeared to be working.

Thanks for your help!  This issue can be closed.

 

 

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...