Jump to content

Install on ARM64 Ubuntu

Cody Salyer

Recommended Posts

I'm trying to install on a Ubuntu machine but get the following error:

package architecture (amd64) does not match system (arm64) is there a version that supports 64 bit arm processors?

Link to comment
Share on other sites

That's not an ideal scenario, i'm not terribly familiar with Ubuntu yet. Also as i'm trying to get Qtcreator installed i'm getting errors back saying there's no installation candidate. that qtcreator isn't availible but it's replaced by qtchooser. 

Link to comment
Share on other sites

  • 1 year later...

FYI - I was able to build synergy for arm64 on the latest Ubuntu MATE.  Version 1.11.0-stable-0badc0de.  Its working great for me.  Let me know if you'd like the binaries or anything :)


Link to comment
Share on other sites

  • 2 years later...

I have the same / similar issue.

Debian arm64 version of Synergy Pro 1.14.6 will NOT install on Ubuntu 22.10 on a Pi4 with 8 GB RAM.  I ran into nearly exactly the same thing with Pop!OPS on the same hardware too...

x@bebhionn:~/tmp$ sudo dpkg -i synergy_1.14.6-snapshot.88fdd263_raspios_arm64.deb 
(Reading database ... 160995 files and directories currently installed.)
Preparing to unpack synergy_1.14.6-snapshot.88fdd263_raspios_arm64.deb ...
Unpacking synergy (1.14.6.snapshot.88fdd263) over (1.14.6.snapshot.88fdd263) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libgdk-pixbuf2.0-0 (>= 2.22.0); however:
  Package libgdk-pixbuf2.0-0 is not installed.
 synergy depends on libssl1.1 (>= 1.1.0); however:
  Package libssl1.1 is not installed.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu4) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
x@bebhionn:~/tmp$ sudo apt install -f
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  dctrl-tools dmeventd dmraid dpkg-repack efibootmgr gir1.2-timezonemap-1.0 gir1.2-xkl-1.0 grub-common grub-efi-arm64 grub-efi-arm64-bin
  grub-efi-arm64-signed grub2-common kpartx kpartx-boot libdebian-installer4 libdevmapper-event1.02.1 libdmraid1.0.0.rc16 libdpkg-perl
  libfile-fcntllock-perl liblvm2cmd2.03 libqt5designer5 libqt5help5 libqt5positioning5 libqt5sensors5 libqt5test5 libqt5webchannel5
  libqt5webkit5 libtimezonemap-data libtimezonemap1 lvm2 os-prober python3-dbus.mainloop.pyqt5 python3-gi-cairo python3-icu python3-pam
  python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebkit python3-pyqt5.sip rdate thin-provisioning-tools
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
0 to upgrade, 0 to newly install, 1 to remove and 99 not to upgrade.
1 not fully installed or removed.
After this operation, 5,094 kB disk space will be freed.
Do you want to continue? [Y/n] y 
(Reading database ... 160995 files and directories currently installed.)
Removing synergy (1.14.6.snapshot.88fdd263) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu4) ...

I can find any packages like libgdk-pixbuf2.0-0 or libssl1.1...  How do I get the software I bought to work on my hardware?

I'd really rather not have to compile / build - are there any arm64 binary packages for LINUX other than the Debian  / Raspbian one?

On 3/19/2020 at 11:18 PM, Jamie Newbon said:

We do indeed have ARM64 binaries available, they were built on a Ubuntu 18 OS and can be selected on the downloads page

Nothing there like that right now, the only arm64 binaries I can see are for Raspbian/RasbpiOS and MacOS

Note also - I was previously successfully able to run the arm64 package on Ubuntu 22.10 - but I have since lost that install - which started out as a Ubuntu 20.04, I installed Synergy in 20.04, then it was progressively upgraded to 22.04, 22.10... I'd rather not have to do that again just to get Synergy to work...

Link to comment
Share on other sites

  • 9 months later...

@Jariah - I've previously downloaded the arm64 DEB (for Raspbian) 1.14.6 for arm64 (Raspberry Pi) and installed it - I don't know if they've fixed the TLS / SSL issue - but I keep a deb file "libssl1.1_1.1.1f-1ubuntu2_arm64.deb" in the same folder as my Synergy 1.14.6 installers.

Symless should make that available - took me a few days to find it - maybe here https://ubuntu.pkgs.org/20.04/ubuntu-main-arm64/libssl1.1_1.1.1f-1ubuntu2_arm64.deb.html (direct : http://ports.ubuntu.com/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2_arm64.deb)

I have installed above on Ubuntu 23.04 on Pi4, Pop!_OS 22.04 on Pi4, and now on Kali (2023) arm64, on Pi4...  Works on all three that I've tried so far.   I have a couple of OrangePi, but not using desktops at the moment (Orange Pi+ 2E running Armbian 16 headless - i.e. Ubuntu 16 for armhf / armv7l [32 bit] - yeah it's EOL but I don't care).

Install libssl first (e.g. sudo dpkg -i ./libssl1.1_1.1.1f-1ubuntu2_arm64.deb) - then install Synergy...

Unless you're talking about Synergy 3? I tried it once (I run MacOS and Linux across my desk on 4 computers) and didn't like it - so went back to 1.14.6 (and you're right, there don't seem to be any DEB packages for Synergy 3 for arm64/aarch64 - the last correspondence I received [as an early adopter] was "we're working on it" for arm64 / Raspberry Pi).

Synergy is actually holding me back from using Wayland (note - if you're running Wayland by default on Ubuntu on arm64, you will have to set it to X11 to use Synergy 1.x).



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...