Jump to content

Hello! 👋

These forums are now archived (read only).

Join us on Discord.

[Fixed] Spacebar types the letter "s"


walter

Recommended Posts

Guest Jerry Hou
Hi guys, please send us some logging with Debug1 level. Please try to make the log as short as possible. Here is some suggestions 1. Make sure this issue happens reliably on your machines. 2. Stop Synergy and close GUI 3. Reopen GUI and change logging level to Debug1 4. Click apply 5. Do the same thing on both server and client 6. Move cursor to client and type spacebar 7. If the problem persists, stop both server and client. 8. Copy logs within the GUI window and paste it into a reply in this forum 9. Add your OS info, input language and physical keyboard layout from both your server and client. Thanks
Link to comment
Share on other sites

  • 2 weeks later...
Cristhian Benitez
On the mac (The Client): [2016-04-23T10:50:09] DEBUG1: recv key down id=0x00000020, mask=0x2000, button=0x0039 [2016-04-23T10:50:09] DEBUG1: mapKey 0020 (32) with mask 2000, start state: 0000 [2016-04-23T10:50:09] DEBUG1: find best: 0000 2000 [2016-04-23T10:50:09] DEBUG1: best key index 0 of 11 (exact) [2016-04-23T10:50:09] DEBUG1: found key in group 0 [2016-04-23T10:50:09] DEBUG1: state: 0000,0000,0000 [2016-04-23T10:50:09] DEBUG1: flip: 0000 (0000 vs 0000 in 0000 - 0000) [2016-04-23T10:50:09] DEBUG1: desired state: 2000 0000,0000,0000 [2016-04-23T10:50:09] DEBUG1: flip: 0000 (0000 vs 2000 in ffff - 6020) [2016-04-23T10:50:09] DEBUG1: mapped to 002, new state 0000 [2016-04-23T10:50:09] DEBUG1: keystrokes: [2016-04-23T10:50:09] DEBUG1: button=0x0002 virtualKey=0x0001 keyDown=down client=0x0000 [2016-04-23T10:50:09] DEBUG1: recv key up id=0x00000020, mask=0x2000, button=0x0039 [2016-04-23T10:50:09] DEBUG1: keystrokes: [2016-04-23T10:50:09] DEBUG1: button=0x0002 virtualKey=0x0001 keyDown=up client=0x0000 [2016-04-23T10:50:15] DEBUG1: recv mouse down id=1 On the server: [2016-04-23T10:51:25] DEBUG1: hook: 0x07002020 0x00390001 [2016-04-23T10:51:25] DEBUG1: event: Key char=32, vk=0x20, nagr=0, lParam=0x00390001 [2016-04-23T10:51:25] DEBUG1: new mask: 0x2000 [2016-04-23T10:51:25] DEBUG1: new mask: 0x2000 [2016-04-23T10:51:25] DEBUG1: onKeyDown id=32 mask=0x2000 button=0x0039 [2016-04-23T10:51:25] DEBUG1: send key down to "iDoraPro" id=32, mask=0x2000, button=0x0039 [2016-04-23T10:51:25] DEBUG1: hook: 0x00000020 0x80390001 [2016-04-23T10:51:25] DEBUG1: hook: 0x06012020 0x80390001 [2016-04-23T10:51:25] DEBUG1: hook: 0x07002020 0x80390001 [2016-04-23T10:51:25] DEBUG1: event: Key char=32, vk=0x20, nagr=0, lParam=0x80390001 [2016-04-23T10:51:25] DEBUG1: new mask: 0x2000 [2016-04-23T10:51:25] DEBUG1: new mask: 0x2000 [2016-04-23T10:51:25] DEBUG1: onKeyUp id=32 mask=0x2000 button=0x0039 [2016-04-23T10:51:25] DEBUG1: send key up to "iDoraPro" id=32, mask=0x2000, button=0x0039 [2016-04-23T10:51:26] DEBUG1: try to leave "iDoraPro" on right [2016-04-23T10:51:26] INFO: switch from "iDoraPro" to "DoraServer10" at 1,295
Link to comment
Share on other sites

  • 2 weeks later...
Diego Sapriza
This still happens. System Version: OS X 10.11.4 (15E65) Kernel Version: Darwin 15.4.0 :oops: Makes synergy almost unusable.
Link to comment
Share on other sites

Martin1491393348
I have the same issue, Windows 7 as a server with a Spanish microsoft Keyboard and a macbook pro with El Capitan as a client, an some key are not goo mapped, but the big problem is the s when I press spacebar. Please doy ouy have the fix for it? also how can remap the key in mac? If i can fix it soon I'll request the refund, because it is not work for me as I need. thanks
Link to comment
Share on other sites

  • 2 weeks later...
Oscar Bautista
I have the same problem using macbook pro an imac. Server imac or server macbook,spanish ISo, its the same. I have payed for nothing i cant use.
Link to comment
Share on other sites

  • 4 weeks later...
Juan José Relaño Laura
I have the same problem. iMac 10.11.5 as server, MacBook Pro 10.9.5 as client. Both in Spanish.
Link to comment
Share on other sites

Richard Lengyel
It's not just spanish, lots of layout errors in hungarian too. I can't write any hungarian accented characters, such as á, é, ő, I just get aa, ee, oe instead of them. Can't write special characters, such as @, as I have no idea, which key combination lure them out of my keyboard, 'cause it seem like nor the Windows, neither the Mac combos works on any language. I've tried AltGr+V (Win,hun), Alt+2 (Win/Mac,eng), Alt+Q (Mac,hun). I have a Windows 10 server with hungarian layout, and OS X 10.11.5 client with hungarian and english layout
Link to comment
Share on other sites

  • 4 weeks later...
David Martin1491393363
Same issue here: When pressing space bar it produces a "s" in the client. The problem happens always. It's not intermitent. I have tested it having the focus in any text field, in the Text Edit application and the Terminal command line. Always fails. It fails as well when used with other keys like Ctrl or Cmd. I am using Synergy 1.7.6 bought last week from symless.com with all the default options and auto config. Environment: Server: MacBook Pro retina 15inch mid2015. Client: iMac 21.5" late 2015 Both systems use the same OS, language and keyboard layout: Mac OS X 10.11.6 Operating system language (Language&Region in System Preferences): English Operating system Keyboard Layout (Input Source in Keyboard System Preferences): [b]Spanish - ISO[/b] Physical keyboard layout: Spain ISO layout with "ñ" key and "< >" key between the left shift key and the "Z" key. In the server (the macbook pro laptop) I use the laptop keyboard directly. No external keyboard. Server Debug1 output when pressing space bar: [quote][2016-07-27T10:09:40] DEBUG1: event: Key event kind: 10, keycode=49 [2016-07-27T10:09:40] DEBUG1: new mask: 0x0000 [2016-07-27T10:09:40] DEBUG1: onKeyDown id=32 mask=0x0000 button=0x0032 [2016-07-27T10:09:40] DEBUG1: event: Key event kind: 11, keycode=49 [2016-07-27T10:09:40] DEBUG1: new mask: 0x0000 [2016-07-27T10:09:40] DEBUG1: onKeyUp id=0 mask=0x0000 button=0x0032[/quote] Client Debug1 output when pressing space bar: [quote][2016-07-27T10:11:58] DEBUG1: recv key down id=0x00000020, mask=0x0000, button=0x0032 [2016-07-27T10:11:58] DEBUG1: mapKey 0020 (32) with mask 0000, start state: 0000 [2016-07-27T10:11:58] DEBUG1: find best: 0000 0000 [2016-07-27T10:11:58] DEBUG1: best key index 0 of 11 (exact) [2016-07-27T10:11:58] DEBUG1: found key in group 0 [2016-07-27T10:11:58] DEBUG1: state: 0000,0000,0000 [2016-07-27T10:11:58] DEBUG1: flip: 0000 (0000 vs 0000 in 0000 - 0000) [2016-07-27T10:11:58] DEBUG1: desired state: 0000 0000,0000,0000 [2016-07-27T10:11:58] DEBUG1: flip: 0000 (0000 vs 0000 in ffff - 6020) [2016-07-27T10:11:58] DEBUG1: mapped to 002, new state 0000 [2016-07-27T10:11:58] DEBUG1: keystrokes: [2016-07-27T10:11:58] DEBUG1: button=0x0002 virtualKey=0x0001 keyDown=down client=0x0000 [2016-07-27T10:11:58] DEBUG1: recv key up id=0x00000000, mask=0x0000, button=0x0032 [2016-07-27T10:11:58] DEBUG1: keystrokes: [2016-07-27T10:11:58] DEBUG1: button=0x0002 virtualKey=0x0001 keyDown=up client=0x0000[/quote] I hope this helps to identify the issue. Having the space bar not working makes the Synergy completely unusable. If any Synergy developer reads this, please feel free to contact me directly to do whatever test you need to address this issue. Thanks.
Link to comment
Share on other sites

Manuel Castro
I've made it work (at least the s/space issue) on my configuration. Its a couple of iMacs, running both El Capitan. What I did is: - delete the spanish keyboard on both iMacs. reboot both - start synergy - redefine the spanish keyboard, on both more or less like another poster did (but my first try didn't work, don't know why). Note, synergy seems to like havving a US keyboard on the server. It does not matter what it is on the client, it will be mapped. But using spanish on server seems to wreak havoc. Do not know if this will be required on next reboot, fortunately I rarely reboot my machines...
Link to comment
Share on other sites

David Martin1491393363
Manuel, sorry but your workaround works for the issue with the space key, but other keys do not work like: ñ, ¡, º and < . So thanks for sharing it, but I think symless still has to provide a fix for this issue.
Link to comment
Share on other sites

David Martin1491393363
More info on this issue can be found here: [url]https://github.com/symless/synergy/issues/2765[/url]
Link to comment
Share on other sites

  • 2 weeks later...

We are developing a fix for this issue. We currently have a nightly available that you can try - http://symless.com/nightly?filter=issue ... ta-5f2f086

 

Our nightlies change frequently, since they are our working models for developing new features. It will no longer be accessible for download at some point, most likely a few weeks, so you should download it soon.

Link to comment
Share on other sites

Someth changed with nightly build applied (osx 10.11.6). It is still broken on client. Sometimes, when you change input language on client - it outputs wrong characters. E.g. фыdап instead of фывап and zxcvи instead of ячсми, in "russian PC" layout. Stable version was changing characters the other way! As i could see now everything is ok while in english layout.

Link to comment
Share on other sites

  • 1 month later...
Simone Martina

I got a similar problem using Slackare 14.1 as server (with italian keyboard) and Mac OS X 10.11.6 as client. Instead os "s" I got a "z" when I stroke space on Mac OS X. At the beginning of session it works well (stroking space show a space) but after some minute it begin this fuzzy behaviour.

 

I've enabled debug2 and pressing space I got this:

[2016-09-19T18:55:05] DEBUG1: button=0x0007 virtualKey=0x0006 keyDown=up client=0x0000

 

I was very enthusiast about this software but typing Alt+Shift+Space for inserting a simple space is very uncomfortable...

 

Simone

Link to comment
Share on other sites

Simone Martina

I would like to add that the problem is showing only when Linux is the server, meanwhile when Mac OS X is the server everything works well. My Linux is at 64bit, so I've used the 64bit package.

Link to comment
Share on other sites

  • 2 months later...

I_have_seen_at_Git_Hub_that_this_problem_comes_since_2011_and_we_are_coming_to_2017_and_we_still_suffering_this_problem_so_Im_starting_to_think_that_this_is_the_worst_expended_money_in_software_of_all_my_life.

 

Symless_don't_deserve_our_money.

 

At_least_6_years_is_time_enough_to_solve_a_problem_like_this.

Link to comment
Share on other sites

  • Nick Bolton unpinned this topic
  • 4 months later...
Guest
This topic is now closed to further replies.
×
×
  • Create New...