Jump to content

Can't disable Synergy 2 launch on startup (Win10)


Recommended Posts

This issue has been bugging me for a while, where I can't find any intentional way to disable Synergy on startup or stop it at all. The GUI seems to only control the Configuration, but not the service itself. But you only notice that, when out of nowhere your Mouse disapears from your screen and you have to search for the reason why. Only to find out that even though you quit Synergy, you only stopped the Synergy Helper. To stop Synergy itself you have to instead open the Task Manager and stop the service. And do that every time you want to quit Synergy. If you forget that, mouse pointers can magically disapear again. The cherry on top is, that after manually stopping the Synergy Service, I can't use the Synergy Helper anymore. I first have to open the Task Manager and start the service. Only then can I open the Synergy Helper.

Is there configuration or menu I am missing? Because I don't think that this designed to be this akward.

Link to comment
Share on other sites

Actually, I just checked again and it seems like I didn't fix it :/.

If you start the Synergy Helper, you should see its symbol somewhere in the taskbar (depending on your OS). If you right click it, you can choose between 'Disable Synergy' and 'Enable Synergy'. That fixes the problem of having to open the Task Manager to stop Synergy. The Service itself will still be running though, it just doesn't connect to an device.

I still haven't found a good way to disable Synergy launch on startup, though. If you restart your Pc, Synergy will automatically connect you to the last connected device. That means unless you know how to disable Synergy launch on startup on your OS, there are still dissapearing mice :/

Link to comment
Share on other sites


yeah...in earlier versions of Windows, we could run MSCONFIG and modify the startup. I just opened it in Win10 and it directs me to the task manager, where there is startup controls, but not nearly a full list. 

Let's see if other forum users have insights.

Link to comment
Share on other sites

  • 1 year later...

Go to Services.  Find Synergy.  Right-click properties. Change startup type from Automatic to Manual.  But that means you still need to start it manually, either through Services or command line net start synergy

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...