Jump to content

Unable to start the zeroconf: Connection to proxy refused


Ryan Erwin

Recommended Posts

Ryan Erwin

Question 1: How is synergy on Arch Linux auto-started? Specifically I'm running KDE Plasma

Question 2: Can I just edit that file (from question 1) and pass custom environment variables in that auto-start file? Or is there a special procedure?

 

I'm getting the following errors when trying to run synergy...

image.png.636dac0ce447ff95a9896d60f9ba44a9.png

On the horrible network that I'm connected from I have to run a proxy to get almost anywhere on the internet, so I have several proxy variables defined in `~/.zshrc`. If I try to run synergy directly from the KDE Search Bar I get:

image.png.1b0e80751c9a96ffaeaaf7618c3377e4.png

Running the same thing from the console, I get:

% synergy 
QObject::connect: Cannot connect (null)::error(DNSServiceErrorType) to ZeroconfService::errorHandle(DNSServiceErrorType)
("-f", "--no-tray", "--debug", "INFO", "--name", "RyXPS.local", "--enable-crypto", "-c", "/tmp/Synergy.jEcKEu", "--address", ":24800", "--serial-key", "7B76...........REMOVED.FOR.PRIVACY...")

From the command line I'm able to manually override all of the proxy related variables before synergy starts:

HTTP_PROXY= HTTP_PROXY= http_proxy= https_proxy= ALL_PROXY=  synergy

So how do I reconfigure synergy under Arch Linux so that I can disable these variables in the synergy startup?

Link to comment
Share on other sites

  • 2 weeks later...

I was somewhat able to get to the bottom of this.... 

Quote

 

Question 1: How is synergy on Arch Linux auto-started? Specifically I'm running KDE Plasma

 

Somehow the .desktop file is being executed...

/usr/share/applications/synergy.desktop

 

Quote

Question 2: Can I just edit that file (from question 1) and pass custom environment variables in that auto-start file? Or is there a special procedure?

Copy the system wide synergy.desktop file to ~/.local/share/applications/synergy.desktop

From here, you can edit the command line... Note that if you want to change environment variables on this command line, you'll need to prepend "env" to your command line. For mine, I did:

Exec=env HTTP_PROXY= HTTP_PROXY= http_proxy= https_proxy= ALL_PROXY= /usr/bin/synergy 

This seems to get synergy running without the Zeroconf error that was coming up before.... But the actual /usr/bin/synergy GUI still fails to open... Running it from the command line I just get:

*** WARNING *** The program 'synergy' uses the Apple Bonjour compatibility layer of Avahi.       INSERT  
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <http://0pointer.de/blog/projects/avahi-compat.html>
*** WARNING *** The program 'synergy' called 'DNSServiceRegister()' which is not supported (or only supported partially) in the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <http://0pointer.de/blog/projects/avahi-compat.html>
("-f", "--no-tray", "--debug", "INFO", "--name", "RyXPS.local", "--enable-crypto", "-c", "/tmp/Synergy.okRgyh", "--address", ":24800", "--serial-key", "7B...")

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...