Jump to content

Finally working after reinstall


Recommended Posts

I never got Synergy 2.0 running correctly on my Mac/Ubuntu-combo and returned to 1.8.8 in december after many hours of struggling.

I just tried again with 2.0.9. After uninstalling the 1.8.8 versions on both machines I did clean installs and reboots. On the Ubuntu 17.10-machine everything seemed to look fine, Synergy came up, connected with the website, showed a green icon and prompted to install Synergy on other computers. On the Mac, the installer ran fine, app started up, showed a black icon and did NOT ask me to login with the browser. That was it. Man, did I throw some curses.

I decided to put another 2 hours into my busy schedule today for one last desperate attempt in solving the trouble (in case of failure I would have returned to 1.8.8 for the very last time until it would eventually break).

There is nothing special on my computers (except that they use multiple monitors with different resolutions), and doing a really clean install with no remains of any traces of Synergy had been key in former updates. So I not only followed the uninstall-procedures from the forums (for 1.8.x AND 2.x), but did a careful search for files containing [sS]ynergy and [sS]ymless. I found cache-directories that were not mentioned in the forum topics I consulted, so I included them in my uninstall scripts. After another uninstall including those cache-dirs and a new clean install, everything worked as suggested.

Analyzing my notes, I guess that any single, or any combination of the following three actions might have solved the problem. You might try them all:

1. Deletion of the cache directories (in addition to the standard uninstall procedures)

  • Mac: ~/Library/Caches/synergy/ and ~/Library/Caches/Symless/
  • Ubuntu:  ~/.cache/Symless/

2. Setting Chrome as default browser in MacOS

  • I usually have Firefox as default browser and I have strong privacy settings with uMatrix, DuckDuck Go Privacy Essentials and the like. Because the Synergy app did start on the Mac, and the logs showed it connected to the background process, but did not connect with the website, I suspected incompatibilities with Firefox or its privacy settings. I installed Chrome without any plugins or security settings and defined it as default browser on the Mac.

3. Multiple reboots of the Mac

  • This sounds esoteric, but I have the feeling, that I have to restart the Mac at least 2 times after a clean install of Synergy to get it to work.

Let's see how this holds up in the next days.

Link to comment
Share on other sites


Thanks for the information. I'm glad you are operational.

I have to agree that the thorough uninstall is pivotal. Besides using version 1 for years, I've used every version 2 since the first beta. I've learned that I save time if I do a thorough uninstall first. I use a third-party uninstaller to be sure I purge everything.

OTOH, for the last 2 updates I've done the in-place update, just to test the system. I'd say that about once out of every 4 such installs, I still have to go back to a 'squeaky-clean' uninstall/reinstall.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...