Jump to content

2.0.8 won't offer to authenticate with symless.com


Recommended Posts

I came back to synergy after some time of absence and wanted to try 2.0.8 as it just appeared. Running into walls for an hour or so brought me over here but a search didn't really turn anything up that sounded alike. So I'm trying my luck with a new post - here's what happened:

My first attempts to pair a MacBook (10.13) and a win10 machine turned out to be a dead end. The win10 machine seemed to work fine right form the start (lonely icon of the local machine on the synergy window, but at least the machines symbol was shown in "green" - which apparently says its working on that system). Only on the Mac the icon of the local machine always stays grey and I couldn't get them to find eachother.

After several attempts of restarting/reinstalling on both machines I realised, that in the log, the very first line ("Symless User ID") did not match on the two machines. This brought to my attention, that while installing on win, the first action in the synergy app is usually to redirect me to the browser to login with my symless user ... on the Mac this never happened so far.
So I grabbed a spare Mac I had available and gave that a shot ... and guess what - it worked as advertised right the first time - meaning Macbook #2 and my original win10 machine are in 'synergy'.
comparing logs of those two supports my theory that the problem on Macbook #1 is the missing user authentication and therefor it doesn't get brought together with my other machines in the meddling service ...

I have tried all I can think of, that would wipe/reset synergy on my Macbook#1(purging the launch daemon/agent files along with the ~/Library/Symless folder and the app itself) in order to force it to go into the symless user auth routine at installation, but that part just won't come up on this machine. Does anyone have an idea how I could provoke the authentication so the Mac gets matched with the working machines and could join the fun? 



Link to comment
Share on other sites


A couple of our other moderators' are more familiar with your set-up. I'm going to defer to them.

Except to say, I always do a thorough cleaning of all Synergy files before installing. Were I you, I think I'd start over fresh.


Link to comment
Share on other sites

thanks @GranPaSmurf for the quick reply. yeah, I was trying to do so by scraping out every possible trace form the problematic machine and install from scratch. My assumption so far is, I must be missing something on the Mac - something like the auth. token or the user ID that is stored in some place I havent found out yet and thats why it keeps failing back into that weird user id and not prompting me for authentication ... 

the places I am usually "cleaning" upon removal of synergy on the Mac:

  • /Library/Launch Agents/com.symless.synergy.synergy-service.plist
  • /Library/Launch Daemons/com.symless.synergy.v2.ServiceHelper.plist
  • /Applications/Synergy.app
  • ~/Library/Synergy/*

 havent found anything in the keyring that matches synergy or symless ... so I cant figure out where it's stored that quirky userID

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...