Jump to content

Ubuntu -> Windows OK | Windows -> Ubuntu NOT


Erres08

Recommended Posts

Was hoping it would work with the new update :(

When i do a fresh install on both machines it seems te be impossible to use my mouse and keyboard from my Windows machine to connect to my Ubuntu (17.04). 

If i connect the mouse and keyboard to the Ubuntu machine i can use both on the Windows machine. Still there a some minor annoying things;

* When im in a terminal session on the Ubuntu machine it is a hard thing to move the mouse to the Windows machine. When i click on the dashboard of the Ubuntu machine and then try again it is a lot easier.

* I cannot use signs like this on the Windows machine; " ~ |  On the Windows machine i use putty a lot

Firewall on the Ubuntu machine is OFF 

I really want to connect my mouse and keyboard to my Windows machine and then connect to the Ubuntu desktop.

help

Link to comment
Share on other sites

I have the same issue, Windows 10 -> Linux does not work on first try.

When I try to move my mouse from Windows 10 to Linux, the server incorrectly changes to Linux. I have to click somewhere within Windows to change the server back, then try moving to Linx again and it works as expected.

Link to comment
Share on other sites

Mike Danielsson

Close to the same problem for me. I'm using one Ubuntu 16.04 machine and one with windows 10.

Works fine when I use my Ubuntu computer as host except that I cant lower the mouse sensitivity so its a little to high when I'm playing games. Else it works fine.

Using my windows 10 computer as host synergy will stop to function after I cross the screen one time. Some times it will work for up to 5 minutes. When it stop to work I cant cross the screens. The program changes host to my Ubuntu computer where no keyboard and mouse is connected and after some seconds it will set my windows 10 computer as host again. This will repeat it self 3 - 5 times in a row and after that some times it will work for maybe 1 - 5 minutes and after that  go back to the same problem.

Link to comment
Share on other sites

Mike Van Pelt

Here's what I've been seeing:

Soon after I installed 2.something, I could freely use the touchpad/keyboard on the Windows 10 laptop to control my Ubuntu system, or the mouse/keyboard on Ubuntu to control the PC.

At one point, this started becoming less seamless.  I had difficulty getting the Ubuntu mouse/keyboard to go to the laptop.

In the "Unofficial Documentation" page is the answer:

Bring up the Synergy window on the system with the mouse/keyboard you want to use.

Right click on the image of that system.  (The one with the mouse/keyboard you want to use.)

Select "Share from Desktop" on the popup window.

This has been working very reliably for me.  The original 2.something 'serverless' behavior, where I could freely use either system's pointer/keyboard anywhere, isn't working now, but I never want to use the laptop's touchpad/keyboard anyway, so I don't care about that.

Link to comment
Share on other sites

I've been watching this thread. 

Synergy 2.06 was released Monday. So far, with 2 startups and several hours of use, it is working perfectly. I haven't had to open the UI on any of the 4 computers.

I'd say give the new version a try.

 

 

Link to comment
Share on other sites

Mike Danielsson
5 hours ago, GranPaSmurf said:

I've been watching this thread. 

Synergy 2.06 was released Monday. So far, with 2 startups and several hours of use, it is working perfectly. I haven't had to open the UI on any of the 4 computers.

I'd say give the new version a try.

 

 

My problem is the same after the 2.0.6 update.

Link to comment
Share on other sites

22 hours ago, GranPaSmurf said:

I've been watching this thread. 

Synergy 2.06 was released Monday. So far, with 2 startups and several hours of use, it is working perfectly. I haven't had to open the UI on any of the 4 computers.

I'd say give the new version a try.

 

 

Problem still exists.

Seems to be that my mousepointer is not visible when moving from Windows to Linux, log shows im moving between the screens (log sent to support)

Link to comment
Share on other sites

got a update from support;

Hi Robby,

I'm really sorry, this is a known bug that we're working on, particularly affecting users with Ubuntu 17.10. It could be a few months before it's fixed. 

 

yeay

Edited by Erres08
Link to comment
Share on other sites

GranPaSmurf

Not very satisfying, but still the right step for you to have done. Support tickets drive development. It's a better pipeline to the development team than this user forum.

 

Link to comment
Share on other sites

Mike Van Pelt
On 2/27/2018 at 3:42 AM, GranPaSmurf said:

Synergy 2.06 was released Monday. So far, with 2 startups and several hours of use, it is working perfectly. I haven't had to open the UI on any of the 4 computers

 

I was still having to open the UI on 2.06 -- Each morning when I came into work with my laptop, the cursor wouldn't move from my Ubuntu desktop to the laptop.

In the UI, it always had my home Windows 10 PC selected as the server.

Yesterday, I deleted my home PC from the configuration, and this morning, my Ubuntu system is the server, everything works perfectly.  (I use the Work Ubuntu/Laptop configuration a whole lot more than the Home PC/Laptop one.)

What I had always wanted out of Synergy 1.x on the client config was to have a pull-down menu of the last few servers used, so I could select one depending on where I was rather than typing in the IP addresses when I switched.  I'm not sure how this is going to go when I eventually want to use it with my home PC again, but that's likely to be weeks. 

Ideally, the new "No config, just does the right thing" would automatically switch to use my office PC as the server when I am at the office, and home PC when I'm at home.

Hm... Maybe it would have done that if I'd installed 2.06 on my home PC.  I'll have to give that a try. (I think my home PC is probably still on 2.03 or something.  It's been that long since I've used my laptop with my home PC.)

Link to comment
Share on other sites

GranPaSmurf

? It seems like I update in the first few minutes after a new release.

At least when we were beta testing, the updates were forced.

Yeah, I think best practice would be to have each machine use the same version.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...