Jump to content

Beta 5 Clipboard corruption


stuart macmillan

Recommended Posts

stuart macmillan

Hi,

I am having a problem in Beta 5 with clipboard corruption. It seems to be size related but I cant be 100% sure as it seems different on clients.This might be quite long but here goes:

I get the following error when copying the clipboard from client to server:

[ Core ] [2017-10-31T08:45:04] DEBUG: start receiving clipboard data

[ Core ] [2017-10-31T08:45:04] DEBUG: receiving clipboard 0 size=926

[ Core ] [2017-10-31T08:45:04] ERROR: corrupted clipboard data, expected size=926 actual size=0

[ Core ] [2017-10-31T08:45:04] DEBUG: start receiving clipboard data

[ Core ] [2017-10-31T08:45:04] DEBUG: receiving clipboard 1 size=926

[ Core ] [2017-10-31T08:45:04] ERROR: corrupted clipboard data, expected size=926 actual size=0

This is what it looks like when it works:

[ Core ] [2017-10-31T08:46:19] DEBUG: start receiving clipboard data

[ Core ] [2017-10-31T08:46:19] DEBUG: receiving clipboard 0 size=75

[ Core ] [2017-10-31T08:46:19] DEBUG: received client "client1" clipboard 0 seqnum=194, size=75

[ Core ] [2017-10-31T08:46:19] DEBUG: start receiving clipboard data

[ Core ] [2017-10-31T08:46:19] DEBUG: receiving clipboard 1 size=75

[ Core ] [2017-10-31T08:46:19] DEBUG: received client "client1" clipboard 1 seqnum=194, size=75

[ Core ] [2017-10-31T08:46:19] INFO: screen "client1" updated clipboard 0

[ Core ] [2017-10-31T08:46:19] DEBUG: open clipboard

[ Core ] [2017-10-31T08:46:19] DEBUG: empty clipboard

[ Core ] [2017-10-31T08:46:19] DEBUG: add 63 bytes to clipboard format: 0

[ Core ] [2017-10-31T08:46:19] DEBUG: close clipboard

[ Core ] [2017-10-31T08:46:19] INFO: screen "client1" updated clipboard 1

[ Core ] [2017-10-31T08:46:19] DEBUG: open clipboard

[ Core ] [2017-10-31T08:46:19] DEBUG: empty clipboard

[ Core ] [2017-10-31T08:46:19] DEBUG: add 63 bytes to clipboard format: 0

[ Core ] [2017-10-31T08:46:19] DEBUG: close clipboard

I Get the following when I try to copy text from the server to the client:

[ Core ] [2017-10-31T08:49:28] INFO: switch from "server" to "client1" at 0,579

[ Core ] [2017-10-31T08:49:28] INFO: leaving screen

[ Core ] [2017-10-31T08:49:28] DEBUG: open clipboard

[ Core ] [2017-10-31T08:49:28] DEBUG: close clipboard

[ Core ] [2017-10-31T08:49:28] INFO: screen "server" updated clipboard 0

[ Core ] [2017-10-31T08:49:28] DEBUG: open clipboard

[ Core ] [2017-10-31T08:49:28] DEBUG: close clipboard

[ Core ] [2017-10-31T08:49:28] INFO: screen "server" updated clipboard 1

[ Core ] [2017-10-31T08:49:28] DEBUG: sending clipboard 0 to "client1"

[ Core ] [2017-10-31T08:49:28] DEBUG: sent clipboard size=923

[ Core ] [2017-10-31T08:49:28] DEBUG: sending clipboard 1 to "client1"

[ Core ] [2017-10-31T08:49:28] DEBUG: sent clipboard size=923

[ Router ] [2017-10-31T08:49:28] error: ClientProxy: failed to parse message: String extends beyond message buffer bounds

[ Router ] [2017-10-31T08:49:28] error: ClientProxy: failed to parse message: String extends beyond message buffer bounds

I did the beta 5 install over the beta 4. I will try a clean install and test again.

 

Stuart 

 

Link to comment
Share on other sites

  • Synergy Team

Hey, the clipboard issue is a known bug in beta5. The core sends corrupt messages which the new network layer doesn't like. We're fixing this right now.

Link to comment
Share on other sites

  • Synergy Team
11 minutes ago, stuart macmillan said:

Thanks for the update.

Other than this Beta 5 has been great for me!!

Awesome to hear!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...