Jump to content

Beta not working on Mac OS High Sierra and Windows 7


ehsa42

Recommended Posts

Log Links:

Hello, all. I'm having issues with the new beta. Synergy 1 works between my Macbook pro running Mac OS High Sierra and my Windows machine running Windows 7. However, after installing the Synergy 2 beta, all that happens is Synergy on my Windows machine shows a black box with a green bar cycling repeatedly across the screen. On my Mac, I simply see a black box with the name of my computer in it.

Any help would be greatly appreciated. I've signed in and everything without success.

Link to comment
Share on other sites

I disabled my firewall and followed the troubleshooting steps in the guide without success. I have uninstalled and reinstalled on both machines as well.

Link to comment
Share on other sites

One other thing: I notice something in the log file for my Mac that wasn't there before. 

Synergy seems frozen on the "requesting profile snapshot", and, when I move the computer box around, I get the following: 

[ Config ] [2017-10-12T18:04:14] ERROR: Reply status code: 400

[ Config ] [2017-10-12T18:04:14] ERROR: Reply error message: Invalid JSON request: bad numeric conversion: negative overflow

Link to comment
Share on other sites

Okay, I'm not the only one. I was trying to figure out what I was missing, but nothing happens with High Sierra and a Windows 10 computer on the same network side by side. 

Link to comment
Share on other sites

18 minutes ago, KringleKrebs said:

I have so little experience with MAC I hesitate to answer. But is the Windows Firewall fully opened up? NOT disabled, but with the permissions and port opened?

https://symless.com/forums/topic/4208-how-to-use-with-windows-firewall/#comment-17610

https://symless.com/forums/topic/4208-how-to-use-with-windows-firewall/

That certainly looks to have made things work a bit better on my Windows machine, but my Mac still hangs at the "Requesting Profile Snapshot" step and gives the "Invalid JSON Request..." error when I move the computer box around. I'm wondering if maybe there is some kind of port issue or something on the Mac, but I don't know enough about opening ports to fix it. 

Link to comment
Share on other sites

  • 3 weeks later...

Nick,

Already tried running the new beta. It pulls up fine on my Windows machine, but my Mac says "There was a problem connecting to the background service. Retry..."

I've retried and restarted to no avail. :(

Thanks!

Link to comment
Share on other sites

46 minutes ago, Nick Bolton said:

Please try beta5:

 

Forgot to mention I even followed the instructions for completely uninstalling and reinstalling to no avail. Here is what I get in the logs:

 

[ Config ] [2017-11-02T19:09:06] DEBUG: install dir: /Applications/Synergy.app/Contents/MacOS

[ Config ] [2017-11-02T19:09:06] INFO: log filename: /Users/ehsa42/Library/Preferences/Symless/Synergy/synergy.log

[ Config ] [2017-11-02T19:09:07] DEBUG: connecting to background service

[ Config ] [2017-11-02T19:09:07] DEBUG: new added screen pos: 257 161

[ Config ] [2017-11-02T19:09:08] error: rpc connect failed: connect: Connection refused

[ Config ] [2017-11-02T19:09:11] DEBUG: current version is update to date

[ Config ] [2017-11-02T19:09:12] debug: rpc keep alive failed

[ Config ] [2017-11-02T19:09:17] debug: rpc keep alive failed

[ Config ] [2017-11-02T19:09:22] debug: rpc keep alive failed

[ Config ] [2017-11-02T19:09:27] debug: rpc keep alive failed

Link to comment
Share on other sites

  • Synergy Team
10 hours ago, ehsa42 said:

There was a problem connecting to the background service. Retry

Good news. A fix for this will be available later today.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...