Jump to content

only oneway mouse, and doesn siplay cursor


jaap aarts

Recommended Posts

I have synergy2B3 installed on 2 machines which are connected without errors.

but I can only move from my main pc to my laptop, not vise versa, and it doesn't update the cursor on my laptop.

I can select things, just not with a cursor, the old cursor(from my laptop) does still work and is completely independent of my main pc's cursor(the one thats not displayed but should still be on my laptop).

keyboards don't sync either.

clipboards do sync.

 

Edited by jaap aarts
Link to comment
Share on other sites

  • Synergy Team
Nick Bolton

Do you see the same issues in Synergy 1? If not, please wait until beta4 is available (2-3 weeks) which may solve these issues.

Link to comment
Share on other sites

yes I do see the exact same problems in synergy 1.

I am able to type but only when I use my invisible mouse to select the textbox.

will this be fixed in later releases?

are there any hidden dependencies(or unsuported deskop envoirements etc) on linux?

 

right now am only getting connection errors on both sides.

"[ UI ] [2017-08-08T16:43:31] DEBUG: can not find any successful connectivity result for the server screen: 2583"

"[ UI ] [2017-08-08T16:43:31] DEBUG: retry in 3 seconds"

is this the servers again? or should I start a new thread about this with more logs etc?

Link to comment
Share on other sites

Paul Suarez

Please do try it tomorrow @jaap aarts. We are currently having intermittent connection with out cloud server, that's why you are getting 502 errors. Please bear with us on this.

Link to comment
Share on other sites

  • Synergy Team
Nick Bolton

The cloud server is back online thanks to @Andrew Nelless and @Dan Sorahan. Andrew implemented a temporary fix that should keep it online until we release beta4, which includes a much more scalable WebSockets network infrastructure.

Link to comment
Share on other sites

I have tried the solution, but the schema didn't exist (checked with dconf-editor)

but I fixed after turning off Wayland display server.

so I suppose you don't have Wayland support?

the problem is solved in synergy1, currently having connection problems in v2.

making a new thread about this.

Link to comment
Share on other sites

  • Synergy Team

Wait, you're able to use Wayland with Synergy 1? That shouldn't be possible, we don't support it yet.

Link to comment
Share on other sites

no I am not, I turned wayland off.

it was on and I turned it off. (its on by default in arch)

I am looking forward to it, and hope it will become available.

I know it must take a lot of time and effort but I think that it would be a nice feature for after the beta.

Link to comment
Share on other sites

  • Synergy Team

Ah! Got ya. Yeah, we started working on Wayland support in Synergy 1 but we only got the server working and it was experimental (so we didn't make it public/stable). We haven't started on the Wayland client yet (but we did figure out that it's tricky). Once we finish both server and client, we'll make it stable. But that'll most likely be in version 2.1 I'm afraid (due mid-2018).

Link to comment
Share on other sites

As this problem is solved in V1 ill say this is solved, there is no solved button but hey.

I am currently having problems connecting(below), but ill post an update here after that works and I am able to try V2 with this solution.

looking forward to wayland in V2, I think synergy is one of the programs holding them back form "upgrading" to wayland.

Link to comment
Share on other sites

  • 4 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...