Jump to content

Initially set up/ran OK; now client crashes immediately

Beddie Crokka

Recommended Posts

Beddie Crokka

I upgraded from 1.8 Pro on both an MacBook Pro (Late 2007) 17" 2.6GHz C2D as client and an iMac (Mid-2011) 27" 3.4GHz Intel Core i7 as Server, both running OS X El Capitan 10.11.6.

Initially set up went fine apart from the laptop being on the wrong side of my iMac server display (Laptop is on the left, configured as such in 1.8 Pro) and I just had to drag it over to the left of the iMac and everything was fine.

Today I hooked up the laptop and turned it on as usual and while it was logging in I was probing the left of the iMac screen with my mouse cursor impatiently waiting for the connection and my mouse to be able to control the laptop. Apparently it didn't like that today as Synergy 2 Beta crashed without ever showing the initial window or the mouse cursor being able to move into the laptop space. I got the Apple problem report window and tried starting Synergy 2 Beta up again only to immediately crash again. I restarted the laptop figuring that should clear any bad trons living in memory but now Synergy 2 Beta crashes immediately every time with the same error. I don't seem to get any logs written on the laptop from that point forward.

The Apple Problem Report gives this Dyld error message every time:

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY
Dyld Error Message:
 Symbol not found: _os_log_create
 Referenced from: /Applications/Synergy.app/Contents/MacOS/synergy2
 Expected in: /usr/lib/libSystem.B.dylib
I'm including a link to an Evernote note in which I put the full copy of the Apple crash report and all of today's log from Synergy 2 Beta on the MacBook Pro and the iMac.
At this point I'm unable to reconnect.
Link to comment
Share on other sites

Beddie Crokka

Feedback: Unusable. No attempts at helping me with a workaround, so forced to go back to 1.8 Pro if it still works. Already tried the updated Beta to no avail. Sad. Thanks anyway, hope you guys get things sorted out sooner rather than later.

Link to comment
Share on other sites

  • Synergy Team
Nick Bolton

Hey, we're having some scalability issues with our cloud config server, @Andrew Nelless is frantically working to fix this now.

And thanks for letting us know about the crash!

@Andrew Nelless Did you see the in the crash report?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...