Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Connection Refused


Recommended Posts

No everything has stayed the same. Same wifi, checked the IP address, auto-configured client, added rules/permissions to the antivirus and firewall, restarted computer, restarted router, uninstalled and reinstalled new Synergy on both computers. Still nothing. 

Link to post
Share on other sites
  • 1 year later...

I was experiencing the connection refused issue (Synergy 1.10.1-stable-8941241e / OS X 10.11.6 on server / OS X 10.12.6 on client). I found that disabling IPv6 on the client side resolved the issue.

The clue for me was the in the connection log, I could see that Synergy was resolving my "Wills-Mac-Pro.local" address to its IPv6 hexadecimal equivalent. As soon as I disabled ipv6 on the client side, Synergy resolved "Wills-Mac-Pro.local" to its decimal IPv4 equivalent and connected immediately. I didn't want to directly configure Synergy using fixed IP addresses as they are dynamically assigned via DHCP.

Link to post
Share on other sites
  • 1 year later...
Peter Cornelius
On 2/26/2019 at 10:04 AM, willrice said:

I was experiencing the connection refused issue (Synergy 1.10.1-stable-8941241e / OS X 10.11.6 on server / OS X 10.12.6 on client). I found that disabling IPv6 on the client side resolved the issue.

The clue for me was the in the connection log, I could see that Synergy was resolving my "Wills-Mac-Pro.local" address to its IPv6 hexadecimal equivalent. As soon as I disabled ipv6 on the client side, Synergy resolved "Wills-Mac-Pro.local" to its decimal IPv4 equivalent and connected immediately. I didn't want to directly configure Synergy using fixed IP addresses as they are dynamically assigned via DHCP.

I was trying to connect Synergy 1.11.1-stable with an Ubuntu server and windows client.  The above was the problem but I was able to just use the IPV4 address of the server in the client config and it started working.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...