Jump to content

Multiple Users


Recommended Posts

Is there a way to configure Symless such that multiple users on the same Mac can utilise the benefits?  I do not appear to be able to set this up and find it to be a significantly limiting factor as I have to delete the app and reinstall it if I wish to use with a different user account.

Edited by RonBertie
Link to comment
Share on other sites

Hey Paul, for complete clarity, I tried a reinstall and confirmed my thoughts.  It did not prompt me to ask about multiple users.


Link to comment
Share on other sites

Paul Suarez

It could be due to the fact that it's not the first time that you have installed Synergy on that machine. You can only see that prompt if you are installing for the first time. Re-installing it after you uninstall it doesn't remove the everything, your machine still knows that you have installed that before.

If you're using macOS Sierra, try this.

Create a group

A group allows multiple users to have the same access privileges. For example, you can grant a group specific access privileges for a folder or a file, and all members of the group have access. You can also assign a group specific access privileges for each of your shared folders.

  1. Choose Apple menu > System Preferences, then click Users & Groups.

  2. Click the lock icon IL_LockSysPrefs_osx.png to unlock it, then enter an administrator name and password.

  3. Click the Add button IL_AddListItem_osx.png below the list of users.

  4. Click the New Account pop-up menu, then choose Group.

  5. Give the group a name, then click Create Group.

  6. Select each user and group you want to add to the new group.

From: macOS Sierra: Set up users, guests, and groups on your Mac

Link to comment
Share on other sites

Hi Paul,

I tried this and set file sharing up but this did not change the situation.  While I could see into the other user's folders I could not run Synergy, the icon remained greyed out.  Do you have any other ideas?

Thanks, Ron

Link to comment
Share on other sites

Hey Ron,

I also experienced this issue and kind of found the way around.

What I did was simply changed the access permission attributes of Synergy.app and all the files under its package. Here's the procedures:

  1. Grant read/write access to everyone account for Synergy.app.
  2. Dig into package details of Synergy.app.
  3. Grant read/write access to everyone account for all items under Contents folder.

Please bare with me adding a large screenshot image which includes Japanese locale.

I'm not sure if this is the right way to handle this issue but it at least enabled me to launch Synergy.app with multiple users. However, I still have a problem sending key stroke to multiple user accounts so need to ask for help on this...

Anyways, I hope this helps you in some ways. ;)



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...