Jump to content

Laggy Mouse


LeatherMan

Recommended Posts

Hi, I was running 1.8 on a windows 10 notebook as server across to a server 2013 r2 client.  I have been running synergy for 6 months and have not had a single problem with lag.  Suddenly, I'm getting ping time spikes when I ping the server from 100 to 300 ms which, of course, correspond to the mouse cursor lag.  I then upgraded both sides to 1.9 to see if that would clear the problem and it hasn't.  I'm not happy as I've loved this product because it's never lagged before.  My priorities are set at realtime on any synergy related processes as well as the use as administrator setting.  Any idea what would cause the sudden degradation in performance of the mouse and any ideas on how to fix it or debug the source of the problem?

Edited by LeatherMan
improve clarity
Link to comment
Share on other sites

Windows 10 is always doing its updates. Server 2012 (prior typo, sorry) as well.  As you know the OS and java, adobe, etc., are always updating.  I'm relatively adept, but IT is not my profession.  What do you recommend?  I see a lot of postings on Apple OS having issues but not much on debugging an windows to windows issue.  Where's the best place to start monitoring traffic to identify the source?  Is there away to rule out Synergy itself as the source of the high ping times?  Very newbie, I know.

The synergy server sits on a notebook connected via wifi.  The client sits on my server and is hardwired into the router.  I think it's the traffic associated with the notebook with the Synergy server that's generating the high ping times.

Edited by LeatherMan
clarity
Link to comment
Share on other sites

Also, I'm seeing this when I start/restart and this seems new so I'm not sure it's related to the laggy mouse problem, but I don't the the normal verbiage about connecting, etc., even though it is working across the two machines.

 

INFO: connecting to service...

[2017-07-10T08:44:33] INFO: connection established

[2017-07-10T08:44:25] INFO: activeDesktop:Default

[2017-07-10T08:44:26] ERROR: failed to get desktop path, no drop target available, error=2

[2017-07-10T08:45:08] INFO: starting server

[2017-07-10T08:45:08] INFO: config file: C:/Users/Artwork/AppData/Local/Temp/Synergy.lN4084

[2017-07-10T08:45:08] INFO: log level: ERROR

[2017-07-10T08:45:09] INFO: activeDesktop:Default

[2017-07-10T08:45:09] ERROR: failed to get desktop path, no drop target available, error=2

[2017-07-10T16:02:03] INFO: starting server

[2017-07-10T16:02:03] INFO: config file: C:/Users/Artwork/AppData/Local/Temp/Synergy.Gg4084

[2017-07-10T16:02:03] INFO: log level: ERROR

[2017-07-10T16:02:05] INFO: activeDesktop:Default

[2017-07-10T16:02:05] ERROR: failed to get desktop path, no drop target available, error=2

[2017-07-10T16:02:35] INFO: starting server

[2017-07-10T16:02:35] INFO: config file: C:/Users/Artwork/AppData/Local/Temp/Synergy.Dq4084

[2017-07-10T16:02:35] INFO: log level: ERROR

[2017-07-10T16:02:35] INFO: activeDesktop:Default

[2017-07-10T16:02:35] ERROR: failed to get desktop path, no drop target available, error=2

Link to comment
Share on other sites

Paul Suarez

Please post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Link to comment
Share on other sites

Paul Suarez

There's a possibility that what you have is a secondary interface for Synergy and that it is already running in the background. For you to see the actual logs, try to stop that, then close Synergy and relaunch it.

Link to comment
Share on other sites

Paul,

Thanks for the input.  I installed input director and see the same lag issue. So, I'm trying to use wireshark and my resource monitor to figure out what high priority process is hammering my I/O off the Synergy Server side.

Regards,

Bill

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...