Jump to content

Synergy hangs when a screenshot is copied to clipboard


Recommended Posts

There are at least two bug reports about this already:

Server:   Arch Linux
Synergy version:  1.8.8-2
Client:   Windows 10
Synergy version:   1.8.8-stable-c30301e
To reproduce, simply copy an image to the clipboard beyond a certain size.   It need not be enormous, perhaps 1280x720 or so.
Logs were included in the open github issue here:
This has been a frustrating problem which has persisted for a long time now.   Please look into this!
Link to comment
Share on other sites

Paul Suarez

 This is the first line on your server log from that link for the zip file.

[2017-01-05T16:31:44] DEBUG1: logging to file (/var/log/synergy/synergy.log) enabled

We might need to have a fresh new set of logs for this. Please follow up on that open issue where you have commented in GitHub. It would be better that way since it is one of our developers who opened that issue. Also, might as well use reactions in GitHub. That helps to get more attention.

Link to comment
Share on other sites

Paul,  after months of no traction on this I emailed a contact at synergy directly and Josiah asked me to post here on this forum!    

Link to comment
Share on other sites

Paul Suarez

I understand @disco. Are you connecting your machines with SSL encryption? If so, have you tried reproducing it while SSL is switched off?

Link to comment
Share on other sites

Hi Paul,

Sorry I didn't see that this post was updated.   

I just tried without SSL and it did not fix the problem.


Link to comment
Share on other sites

5 hours ago, Paul Suarez said:

Can you provide us screenshots of the user interface on both machines as well as the logs it shows?

@Paul Suarez   I added updated logs to the github issue several weeks ago:


I have no idea how you think a screenshot could be helpful.  It certainly would not be possible to take a screenshot of the app when the bug is triggered, as this locks up the entire Xwindows UI.     I have to ssh in from console to kill synergy.

Multiple other people have complained about similar issues on multiple github issues relating to the same topic.    There's nothing special about my setup, this must be trivially reproducible. 

Something to do with passing of clipboard image content beyond a certain size.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...