Jump to content

Mouse clicks not recognized when entering other machine's screen


Josh Borges

Recommended Posts

Josh Borges

I am having the same issue with 1.8.8 on Windows 10 x64 latest branch.  I have to click in the server system to be able to click in the client system.   then it only works for a click or two before I have to go back to the server and click to get it working again.  

 

Edited by Josh Borges
Link to comment
Share on other sites

Paul Suarez

Hey @Josh Borges. I saw you have already replied to three threads (including this) made by other members. I that comment you made and made it as a different thread.

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server).

Link to comment
Share on other sites

Josh Borges

both systems are window 10 Pro x64.  Server is a wired connection.   Client is wifi connected.   Both systems are running 1.8.8

Link to comment
Share on other sites

Paul Suarez

Can you post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine?

Link to comment
Share on other sites

Paul Suarez

Basing it on the screenshots, your server machine is using the 192.168.x.x as primary interface. Since your client is not connected to that network, it can't communicate to the server machine. Which network would you want the machines to communicate through?

Link to comment
Share on other sites

Josh Borges

192.168.x.x is not the primary network.  That is a vnic in VMWARE Workstation and VMWARE not running.   My real network is the 172.16.1.x.   Connection is not an issue.   I can click after coming over from the server but then it will stop and then I have to clink in the server window to be able to click in the Client window.   I did notice that the problem seem to stop when I closed Skype for Business.  

 

Edited by Josh Borges
Link to comment
Share on other sites

Paul Suarez

If one or all of your computers have multiple IP addresses, it could be that Synergy is trying to look for the other computers on the network. This may not be the same network where your other computer is trying to send its connection request to. What you can do is to set an interface where your computer will be looking for or will be listening to for the other computer's request to connect.

Do this on your server machine first

  1. On Synergy's user interface, click Edit
  2. Click Settings
  3. Use the IP address of that machine where you want it to listen or look for the other machine, type it in the box next to Interface
  4. Click OK
  5. Click Apply or Start

Most of the time, setting it only on the server machine is sufficient. But if still won't connect, go ahead and set it on your client machine as well or you can opt to manually input the server IP instead of using Auto config.

Link to comment
Share on other sites

  • 2 weeks later...
Josh Borges

Setting this still does not fix the issue.   I have to close Skype for business (LYNC) and it works no problem.   I would prefer not to have to close this application.

Link to comment
Share on other sites

Paul Suarez

Can you try connecting it again while Skype for Business is closed then re-launch it after Synergy connection is established?

Link to comment
Share on other sites

  • 1 month later...

This makes no difference.   I am noticing that I see the same issue with VMWare Workstation installed with advance keyboard functions enabled.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...