Jump to content

Cannot connect client to server - failed to connect to server: timed out


Keezo

Recommended Posts

I had the exact same problem that the OP described; windows 10 and mac 10.10.5 with different IP's (subnets?) and the client couldn't connect.

My Windows 10 server listed several different IP's (some were off the screen, so I stretched the synergy window).

I did what estraulino suggested and it fixed it.

TLDR: on the client, enter the server IP that's not in bold and shares the same 3 initial numbers, i.e. 192.168.0.x

Link to comment
Share on other sites

The only problem I have now is that on my "server" machine, clicking webpage links takes a lot longer to see the webpage.

I have fiber and clicking on links used to (before installing Synergy) show a webpage instantaneously.

Now it takes about 10 secs.

 

I suppose that DNS lookups are going through a new virtualbox network connection? Maybe through the client?

Can this be fixed ?

Link to comment
Share on other sites

  • 4 months later...
  • 1 month later...

I was having the same issue, trying to connect Windows 10 64 bit (server) to my Macbook Pro Mojave 2015 (client). I nearly gave up and asked for a refund but managed to connect...

  • make sure the screen name are consistent across the two machines (i.e. make sure the computer names in the 'Configure Server' option tab. For example, my Window laptop is RAZER and this should also be the same on the Mac side, and vice versa)
  • I did not use the recommended auto IP configuration option
  • I did not use the recommended IP address shown in my server machine for my client to connect to... what I did was I found out the IP address my server  and just used that for my client to connect to. I did this by checking the Router setting page (i have a cheap ISP default router) and see what my IP address is.

It worked for me... i hope it does for you too.. i think the missing key here for me was that the names have to be consistent...... the software must use it as the USER ID or something... 

Link to comment
Share on other sites

Hey

This is normally caused by a firewall issue. Please, could you try temporarily disabling your firewall to see if this resolves the issue? If it starts working, let me know and we can setup a rule to allow Synergy. If not, it could be that the IP address you're trying to connect to is invalid, or maybe the server isn't running. Either way, I'm happy to help.

More troubleshooting info for this issue:
https://symless.com/help/s1-troubleshooting/s1-connection-issue

Link to comment
Share on other sites

  • 3 months later...

I have having a similar issue.  I know it is not selinux or the firewall. I disabled selinux and the firewall and still have the same issue.  My server is a centos 7 machine and client is a windows 10 machine.  It worked up until 2 days ago when I had to reinstall my linux machine.  I have tried everything.  Below is the image of my synergy clients on the machines:

centos

synergy_centos.thumb.png.dd0039fb0cd5d862a29515f4fb08f520.png

 

windows 10

synergy_win10.thumb.PNG.cf0aa7d9e464eadeceafe5b6059acc97.PNG

Link to comment
Share on other sites

  • 2 weeks later...
On 2/12/2019 at 6:45 PM, sonbemi said:

I have having a similar issue.  I know it is not selinux or the firewall. I disabled selinux and the firewall and still have the same issue.  My server is a centos 7 machine and client is a windows 10 machine.  It worked up until 2 days ago when I had to reinstall my linux machine.  I have tried everything.  Below is the image of my synergy clients on the machines:

centos

synergy_centos.thumb.png.dd0039fb0cd5d862a29515f4fb08f520.png

 

windows 10

synergy_win10.thumb.PNG.cf0aa7d9e464eadeceafe5b6059acc97.PNG

Is the client "screen name"/hostname the same after reinstall? If no you may have to update your server config file or use interactive config to create a new config file.

Link to comment
Share on other sites

Hi,

Can you please claridy updates version that you have installed on your Win client machine? 

We are aware about this problem but issue effected only on Win 10. 

So, here is short workaround : 

1. Delete latest installed updates.

2. Reinstall Synergy from Fresh. 

Link to comment
Share on other sites

  • 2 weeks later...
Uglycasanova

I'm getting the failed to connect issue on 1 of my 3 synergy systems.  
Setup is as follows:

Server - Fedora 28 (working ok)
Client 1 Windows 10 (working ok)
Client 2 Mac desktop on Mojave 10.14 (failed to connect error)

I got this error after updating OSX and Synergy the same day, so unfortunately I can't say what caused the error, but my setup was working well for about a year.  
I know my settings are correct (correct naming, and I don't use the bold suggested ip), and I have even tried to disable the firewall on OSX, but my mac is simply refusing to connect.  At this point Im just waiting for a update (or synergy 2) to be released, hoping that resolves it.  
 

Link to comment
Share on other sites

  • 2 months later...

i bought synergy to work at my office with my mac and my pc (CPU) it NEVER worked. Tried everything for months including this kind of forums. I want a refund, how can i get it? very dissapointed with the program.

Link to comment
Share on other sites

  • 5 months later...

After working for it for a couple of hours I figured it out.

 - First, ipconfig on the windows machine and make sure you are connecting to the correct IP, don't assume its the bolded one.

 - Then attempt to ping each IP from machine to machine (if this doesn't work debug that first)

 - Verify that you haven't messed with any of the port settings in either machines synergy config settings (this was my issue)

 - Either create a rule for synergy in windows firewall or just disable firewalls for testing

 - verify your spelling and numbers are correct everywhere (another issue I had)

After doing all these I finally got it working, Good luck!

Edited by Erik M
Link to comment
Share on other sites

  • 2 years later...

I know this is an old issue, but I feel compelled to mention that 192.168.1.x and 192.168.137.x can communicate just fine, and in fact, are the same network, if both machines use a subnet mask of 255.255.0.0. We should not assume everyone uses 255.255.255.0.

Link to comment
Share on other sites

  • 10 months later...

Hi everyone,

I too encountered this problem and maybe my fix will help some.

As Mathieu points out, many issues can be due to a configuration issue locally (in your home) and specifically your internet box/router.

In my case the problem was that my server computer (windows 11) had an obscure name (letters & numbers) on my local network as it was setup automatically by my network provider.

After naming the server computer the same on my local network (through the internet box/router interface) and in synergy the connection worked.

Note that we're not talking about the name of the computer in windows, it has to be the name of the computer as configured on your local network in your router. This has to match with the name of the computer in Synergy.

In case this still doesn't solve it for you, the next step would be to check if port 24800 is not blocked for your server computer for some reason. Again this setting would be accessible through your router's interface.

Try to get it to work folks, because when it does it's pretty awesome!

@Synergy devs: an auto detect function so that the software automatically matches the name in synergy with the name on the local network could be a nice fix.

Link to comment
Share on other sites

  • 1 month later...
On 11/14/2017 at 1:48 AM, estraulino said:

Hi @Alsatian

I still think I got lucky, and I'm no expert, but I'll try to explain what I did better so that you might try if it works:

5a0a48649f2c5_MacScreen1.JPG.f53e5eadf6871ef3f2c2ddad8dd4572d.JPG

In my Mac the address is 192.168.1.65,

 5a0a48a4d1106_WinScreen2.JPG.4e6c20f47ed7a0e6e8f0897a705f5498.JPG

And in my PC I have 4 addresses, one is in bold, meaning is the one recommended that you use, but the 3rd number does not match the Mac Ip Address. My Mac has a XXX.XXX.1.65, and my PC IP address thats is recommended for the connection is XXX.XXX.137.1. As you can see in the first image, Synergy is configured with the recommended address but is not connecting. But there is another address (marked in yellow) that is similar to my Mac's IP address (XXX.XXX.1.70) since the 3rd number is 1.

5a0a4a120845a_MacScreen3.JPG.ef4ed4233037df2b140586d675e34742.JPG

As you can see, when I use the XXX.XXX.1.70 address for my server, it starts working.

See if you can find in the addresses listed by Synergy which ones are similar and try using those for Synergy.

I have a simple ISP provided wireless modem, no fancy stuff.

I should note that Synergy reseted the Server Adress on the client and I had to change the address again when connecting the Mac again after being out on a trip.

Hope this might help someone.

This helped me massively.

Thank you very much Alsatian

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...