Jump to content
Get SynergyOpen a support ticket

Infinite error loop, wont start


Recommended Posts

Synergy worked for about a week, but has since stopped working. Now, the server throws constant error messages and the client refuses to connect. The server is running windows 10 64bit with the latest update, and the client is running macOS sierra 10.12.5.

Here is the log from the server:
[2017-05-31T22:42:22] INFO: watchdog status: error
[2017-05-31T22:42:27] INFO: starting server
[2017-05-31T22:42:27] INFO: config file: C:/Users/RYANLO~1/AppData/Local/Temp/qt_temp.gq2700
[2017-05-31T22:42:27] INFO: log level: INFO
[2017-05-31T22:42:27] INFO: service command updated
[2017-05-31T22:42:28] INFO: starting new process
[2017-05-31T22:42:28] INFO: activeDesktop:Default
[2017-05-31T22:42:28] INFO: starting new process
synergys.exe: address not found for: hide
Try `synergys.exe --help' for more information.
[2017-05-31T22:42:31] WARNING: detected application not running, pid=5760
[2017-05-31T22:42:32] INFO: backing off, wait=2s, failures=1
[2017-05-31T22:42:34] INFO: starting new process
[2017-05-31T22:42:34] INFO: activeDesktop:Default
[2017-05-31T22:42:34] INFO: starting new process
synergys.exe: address not found for: hide
Try `synergys.exe --help' for more information.
[2017-05-31T22:42:36] INFO: service command updated
[2017-05-31T22:42:37] INFO: process started but command is empty, shutting down

The client just says "WARNING: failed to connect to server: Timed out" every ~10 seconds. 

Any help would be appreciated. Thanks.

Link to post
Share on other sites
Paul Suarez

Hi @RLong. Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Link to post
Share on other sites

The Server is running 64 bit windows 10, synergy version 1.8.8-stable-25a8cb2. Connected to network via ethernet. 

The Client is a MacBook pro running 64bit macOS Sierra 10.12.5, synergy version 1.8.8-stable-25a8cb2. Connected to network via WiFi. 

I have also attached the screenshots of both interfaces as well as the server config interface. 

Client.png

server.PNG.ff3efc4df2d426535a4d0de841880784.PNGconfig1.PNG.2b879a367e46e63354a9d907c139650d.PNGconfig2.PNG.f5468f9567dcd718c6bead7471e015cd.PNG

Server.png

server config 1.png

server config 2.png

Edited by RLong
pictures were too small
Link to post
Share on other sites
Paul Suarez

Can you check your server machine if Synergy service is running on it and is set to run automatically?

Link to post
Share on other sites

Upon installing the new version and restarting both computers, there was no change in the behavior of the program

 

Link to post
Share on other sites
Paul Suarez

Can you try changing the name of each machine? Then update the changes made in the Server Configuration interface.

Link to post
Share on other sites
Paul Suarez

Have you changed the machines name? If so, please post a screenshot of both machine's Synergy interface

Link to post
Share on other sites
Paul Suarez

How about if you ping the Windows machine from the Mac? After that, try using "arp -a" command on cmd box (without the " "). Send us a screenshot of that. Thanks :)

Link to post
Share on other sites
Paul Suarez

It seems that the windows machine is not reachable. Are there any changes in the IP address assigned to each of the machines before you made the ping command on your Mac?

Link to post
Share on other sites

Problem solved, in the settings window, I had edited the "interface" line, not knowing what it did. after clearing the interface setting, synergy works perfectly again. 

Thanks!

Link to post
Share on other sites
Paul Suarez
1 hour ago, RLong said:

Problem solved, in the settings window, I had edited the "interface" line, not knowing what it did. after clearing the interface setting, synergy works perfectly again. 

Thanks!

I was about to tell you that. You figured it out first. Good job @RLong. Thanks for the update by the way. ;)

  • Like 1
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...