Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Trouble with multi-language input


Recommended Posts

Vadim Dyachenko
Hi. I've bought Synergy just earlier today - from the first impression, works quite better than Mouse Without Borders. I've quickly bumped into a small problem though. I have two devices - a desktop computer (server), and an average-sized x86 tablet (client). Both are running an English version of Windows 8.1 32-bit. Both have two input languages - English and Russian. The problem is: 1. Switching languages (set to Ctrl+Shift, if that matters) while on the client machine doesn't work as intended - indeed, it switches the language, but if the server' language is set to English, it'll continue sending English text. What is the expected course of action about this? 2. If I change the language to Russian while on the server, switch to client, and try typing something, Cyrillic characters will not successfully "get through", turning into question marks "?". Numbers and punctuation still work correctly (and with keyboard layout differences in mind). I assume that this is an encoding problem, but I haven't found any way to adjust it neither in the options nor on text_config wiki page. Quite curiously, at the same time copying text via clipboard works though. I would imagine that this would be more or less of a common and easily resolvable problem, but so far I was unsuccessful in my searches by related queries.
  • Like 1
Link to post
Share on other sites
  • 6 months later...
  • 2 years later...

similar problem here.

OSX 10.12.6 server, Win10 client. Works fine when server's input language is set to English, but no output registered when server's input language is in Korean.

Link to post
Share on other sites
  • 2 years later...
  • 1 month later...
Dmytry Kulkov

Exactly the same problem. If the server ENG on the client ENG and perklyuchaetsya ENG-RUS. If on the server RUS, on the client RUS and does not switch.

This is very disturbing. I bought the paid version, I thought everything would be fine on the last build. But this is not the case. This is bad, can anything be done about it?

Link to post
Share on other sites
Dmytry Kulkov
1 hour ago, Alexey Pilyaev said:

Hello @Dmytry Kulkov @ZimanWhich OS's and Synergy version you are using?

Server: Win10 64-bit or Win7 32-bit, synergy 1.11.0, 1.10.2, 1.8.8 (all combinations)

Сlient: Raspberry pi, synergy 1.11.0 or 1.10.2

Link to post
Share on other sites
  • 2 months later...
  • 6 months later...
  • 4 weeks later...
Seonghyeon Kim

Hello!

I have similar trouble. 

my configuration:
Server: macos big sur - synergy 1.13.0 stable
Client: Windows 10 64bit - synergy 1.13.0 stable

I use capslock for change input language on mac. when I use hangeul 2-set input methods on mac, synergy keyboard sharing not works at client (synergy keyboard sharing only works  at mac server's input method is English.) and when I pressed caps lock at client to capitalize chars, macos server input method has changed and keyboard not works at client.

 

Link to post
Share on other sites
Seonghyeon Kim

and I think synergy is not designed to multiple input methods environment. at windows client, Korean IME input methods using right alt to change language and it also not works. 

I hope synergy team has priority to this...

  • Like 1
Link to post
Share on other sites
  • 1 month later...
  • 2 months later...
OchaBanana

Hello,

Today I just bought Synergy and my version is "synergy_1.13.1-stable", still got this problem.

Both machines are Windows 10.

Once I move cursor to a client then I press "alt+shift" to change language between Thai<>English, the system in a client shown the language had changed already but when I type the language it's automatically change back to be same language that the Server used. 

Scenario-1: I used English in a Server then move cursor to a client, press "alt+shift" on a client to change to Thai everything looking good but when I type it's has back to English

Scenario-2: I used Thai in a Server then move cursor to a client, press "alt+shift" on a client to change to English it didn't change back to Thai in this time but I got only "???????" when typing even I change to Thai in a client I still got only "???????????" when typing.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...