Jump to content

Unable to install 1.7.5 RPM


Niklas Modin

Recommended Posts

Hi, I'm trying to install the 1.7.5 rpm using yum but there seems to be a missing dependency. $: sudo yum -y install synergy-v1.7.5-stable-fa85a24-Linux-x86.rpm $: Error: Package: synergy-1.7.5.x86_64 Requires libdns_sd.so.1() (64bit) I thought yum would automatically install any missing dependencies ? Any pointers ? Cheers, Niklas
Link to comment
Share on other sites

Did some trial and error but still no success: 1. installed the avahi package to get the missing libs. $: yum install avahi $:Package avahi-0.6.31-15.el7.x86_64 is already installed and latest version 2. Checking for the libdns library $: ldconfig -p | grep libdns $: libdns.so.100 => .... $: libdns-export.so.100 => ... Still get the dependency error for libdns_sd.so.1 (64bit) which I guess makes sens as the above once are ... slightly different. Also tried the 32 bit version with no luck. Linux isn't really my back yard so any pointers on what could be wrong would be appreciated. :) Cheers, Niklas
Link to comment
Share on other sites

  • 3 weeks later...
Any updates on this issue? I'm having the same problem on RHEL 7. While not the most popular distro, it is a fairly standard distro and you would think a synergy install would work.
Link to comment
Share on other sites

  • 1 month later...
[quote="David Miles"]Any updates on this issue? I'm having the same problem on RHEL 7. While not the most popular distro, it is a fairly standard distro and you would think a synergy install would work.[/quote] Hi, Been a while since I visited. I "solved" it by installing Ubuntu 15. Now I'm back on RHEL 7 (OL7) and I'm back with the same issues. Did you ever find a solution for this ? Cheers, Niklas
Link to comment
Share on other sites

Ryan1491393327
OL7 has super dated repos for stability. I was in dependency hell ceaselessly, because it just didn't support any new packages. You're not going to be able to run the latest and greatests of anything.
Link to comment
Share on other sites

Niklas and David, I saw this comment in a Google Groups post: "Very of the cuff guess, trying installing avahi-compat-libdns_sd Just avahi won't cut it is my guess." What happens if you try this? I hope the issue gets resolved, although I don't have a any OL7 RHEL to try out. - Brian
Link to comment
Share on other sites

Hi all, I fixed it by enabling [ol7_optional_latest] in /etc/yum.repos.d/public-yum-ol7.repo. Perhaps I'm now living a little less stable, but YOLO ! :D Thanks for the suggestions and hope this answers helps someone else. Cheers, Niklas
Link to comment
Share on other sites

  • 1 month later...
[quote="Niklas Modin"]Hi all, I fixed it by enabling [ol7_optional_latest] in /etc/yum.repos.d/public-yum-ol7.repo. Perhaps I'm now living a little less stable, but YOLO ! :D Thanks for the suggestions and hope this answers helps someone else. Cheers, Niklas[/quote] How to do that?
Link to comment
Share on other sites

  • 5 weeks later...
Fredrik Andersson
I cant find the file i need to install, dependancy. Searched via Synaptic without luck, got a Pro version so wanna use it on this machine and one of the other ones
Link to comment
Share on other sites

  • 2 months later...
Fredrik Andersson
Tried just now and install the Beta , got the same error. Same same with stable, gonna do some digging around and see, Using Gecko Linux, opensuse tumbleweed based< Other machine gonna be win10 and maybe another one win7, stress test ;)
Link to comment
Share on other sites

  • 1 year later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...