Jump to content
Get SynergyOpen a support ticket

Completely disable edge detection (fullscreen mouse hitching)


Recommended Posts

Ninbura
Posted (edited)

I see loads of posts about gaming on the forums, but I'm not seeing my same problem. To quickly explain, I have hotkeys I trigger via a Stream Deck to switch between my 4 PCs, I prefer this to a traditional USB switch because it switches instantaneously (vs 2-3 seconds) with the added benefit of clipboard sharing. I have a very complicated screen layout where screens are in-between screens connected to different computers, I also have HDMI switches connected to multiple displays to switch between multiple PCs, and EDID emulators to trick each PC into thinking that every display is continuously connected. Here's a picture for reference as I don't think my words can accurately capture the complexity
849974302_ghettoScaled.thumb.jpg.5e0bdccf34b33d09d96d34944dd7956d.jpg

Now imagine an HDMI switch connected to almost every display that lets me switch said display between each computers. Long story short, edge detection simply isn't going to work for me, so I have a multi-action set up via my Stream Deck to always "lock the cursor to screen" when I switch between the server and the clients / vice versa. This way I should be able to guarantee cursor lock every time I switch between each PC, but I'm still having issues...

While in a full-screen game my movements seem to hitch while moving my mouse across great distances, my assumption is that synergy is still tracking for edge detection at times and then checking to see if the cursor is locked, rather than just ignoring all edge detection in general. I tried using the "Dead corners" option, but it only goes to 99 pixels if I'm understanding correctly and doesn't seem to change anything. So far my only solution is to stop Synergy outright, which then requires me to enable it before switching, which ends up being a longer process than using a traditional USB switch thus defeating the purpose.

Is there no way for me to completely disable edge detection?

Edited by Ninbura
Link to post
Share on other sites
Ninbura

If there is no way to totally disable edge detection, has anyone else run into hitching while running a full screen application and Synergy?

It seems to happen in games when I spin quickly to do a 180 for example, I believe synergy is stopping the mouse at the screens edge for a brief moment.

Link to post
Share on other sites
  • Synergy Team
Nico M

You can disable edge detection by separating the computers on the screens and links tab. 

For full screen apps you most likely need to lock the cursor to the screen, which you can do using the Scroll Lock key.

Link to post
Share on other sites
Ninbura
1 hour ago, Nico M said:

You can disable edge detection by separating the computers on the screens and links tab. 

For full screen apps you most likely need to lock the cursor to the screen, which you can do using the Scroll Lock key.

Thanks for the reply, is locking the cursor to the screen via Scroll Lock different than setting a custom hotkey for "lock the cursor to screen"?

Guess I'll have to try separating the computers in the grid to see if that makes any difference. 

Link to post
Share on other sites
  • Synergy Team
Nico M

Yes it is different. One is using the Scroll Lock key, and the other is setting a custom key.

Scroll Lock is used for this function by default.

Link to post
Share on other sites
Ninbura

Well yeah I meant in actual functionality, I mentioned in the original post that I use a Stream Deck to run multiple hotkeys with one press that activates "lock the cursor to screen" every time I switch computers (F23 = "lock the cursor to screen", F13-15 = switch hosts):
Hotkeys.gif.71ed7f60592c7d5eb13cd0b81f4a9edd.gif


I could also see in the log that "lock the cursor to screen" was successfully activated whilst the issue continued to occur. I won't be able to test until later today, but I'll try splitting the PCs up via the grid and using the default lock hotkey.

Link to post
Share on other sites
  • Synergy Team
Nico M

While I can't offer much assistance on the Steamdeck hotkey config, I am sure separating the computers in the screens and links tab will disable edge detection

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...