Jump to content

Asking for hostname, no place to type it.


Bobby Thompson

Recommended Posts

Bobby Thompson

I just updated my synergy client on a Mac and am setting it to be a client.

 

I click start and get a window that says:

 

Please fill in a hostname for the synergy client to connect to.

 

Problem is, the only field in the screen (Server IP) is disabled because Auto Config is checked.

 

So, where am I supposed to type this Host Name??? I am completely down as a result of this update.

Link to comment
Share on other sites

I just updated my synergy client on a Mac and am setting it to be a client.

 

I click start and get a window that says:

 

Please fill in a hostname for the synergy client to connect to.

 

Problem is, the only field in the screen (Server IP) is disabled because Auto Config is checked.

 

So, where am I supposed to type this Host Name??? I am completely down as a result of this update.

 

Uncheck the Auto Config box and the Server IP input field will become enabled.

Link to comment
Share on other sites

  • 2 weeks later...

I'm having the same issue on my Mac client. But I am able to de-select "Auto config" and enter my server's IP address, and connect that way.

Link to comment
Share on other sites

Stephen Longhurst

I has a similar issue. Like Bobby, I can uncheck the "Auto Config" and enter a hostname/IP and the connection works, but I have to do this every time Synergy starts! Can the hostname be saved somewhere?

Link to comment
Share on other sites

While I can uncheck it to enter the host name, mine won't even connect. I had to set my mac to auto launch terminal and run the command line at login.

Link to comment
Share on other sites

Patrick Traylor

I had the same problem after the last upgrade. Synergy displays two IP addresses for my server (PC). I had to uncheck the Auto Config box on the client Mac and type in the IP address for the server PC that began 10.x.xx.xx. They connected (after the PC version of Synergy looked like it crashed, but it didn't). Then I rechecked the Auto Config box. The machines reconnect automatically, but the PC version keeps giving a crash error box anytime there is a connection/disconnection. I ignore the error and things seem to be OK.

 

I love Synergy and it saves me plenty of time in the office where I run the PC box along with my personal laptop. But I will say that after every upgrade, I have to spend an hour or so resetting the configuration so that the machines will talk to each other. I should just stop upgrading . . . !

 

MacBook Air (mid-2011) running macOS Sierra (10.12) (Synergy v. 1.8.4) connecting to some kind of Dell box running Windows 7 Enterprise SP (64 bit) (Synergy 1.8.4. 64-bit).

Link to comment
Share on other sites

  • 2 weeks later...
I has a similar issue. Like Bobby, I can uncheck the "Auto Config" and enter a hostname/IP and the connection works, but I have to do this every time Synergy starts! Can the hostname be saved somewhere?

 

Same problem here! The synergy app won't save the PC name when I type it in the Server IP. It works temporarily but as soon as I reboot the server, I can't connect again. Driving me crazy! I've searched high and low for a .synergy.conf file to type the server name in there, but it doesn't exist!

 

I even ran sudo find / -name .synergy.conf and there is 0 results.

 

Edit: I completely purged synergy on the linux PC and reinstalled and it is keeping the record now. That seemed to fix it for me.

Link to comment
Share on other sites

  • 2 years later...

I had this same issue from my Mac to PC, in the end I went to preferences and disabled automatic configuration, manually typed the IP address of my Windows machine and got on with my life. Symless != seamless in this case >:(

Link to comment
Share on other sites

  • 2 months later...
Bobby Thompson

There is an intestine new caveat to this...

It appears the new version took away the checkbox in question from the window & replaced it with a server dropdown...

A dropdown with nothing in it...

 

Click start and it indicates you must fill in a hostname, but since its a dropdown now that isn't exactly possible...

Link to comment
Share on other sites

I had the same problem as Bobby. 

The first part of this looks like people trying to solve if you mac is the server, i was having trouble with it being a client. I figure it out.

On my mac, i went to Synergy Menu>Preferences>Uncheck 'Enable Auto Config'>ok

now the field change from a drop down to a fillable form text field for the IP

Link to comment
Share on other sites

  • 1 year later...

I am having the same issue I think as Bobby. I am having problems getting my work Laptop to connect to my home pc, and so I thought I might try to switch them around and make the laptop the server and the pc the client, just to see if it works that way. With my Home PC as the client, it won't allow me to enter the Server to connect to, and then errors out when I click start, saying "Please fill in a hostname for the synergy client to connect to." All while not allowing me to enter anything into that field.

Symless PC.png

Symless laptop.png

Link to comment
Share on other sites

Daniel Alarcon

@dougglez  The suggested solution to disable auto-config is the right one. There is one additional step: Stop and Exit Synergy, then open it again, now the Server text box will be enabled and will allow you to enter the IP address.

@Bobby Thompson  @Scott Connor FYI

@Brian Hansen  If you have to do things all over after a reboot, please do the following, configure it as you normally do, after that, stop Synergy and Quit. Then open it again. This will save the configuration permanently. Hope this helps.  @Stephen Longhurst  FYI

@Greg Heuer  Are you still having trouble?

  • Like 1
Link to comment
Share on other sites

Greg Heuer

@Greg Heuer here. Wow, a reply from a post from 2016? I don't even know what I was trying to do back then. Great to hear from you, tho. I fully retired now. Don't use or even want multiple computers on the desk at this point <grin>.

Link to comment
Share on other sites

  • 5 weeks later...

Just chiming in to say this worked, I've got an Ubuntu 20.04 desktop running server, and a MBP (10.15.4) connected as client. Unticking auto-config and restarting Synergy has sorted it. Thanks Daniel.

Link to comment
Share on other sites

Sure @jovis88

Next time, you can use a link on my or Daniel signature to place a ticket for us and we will be happy to help or organize a remote session :)

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...