Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Cannot install Synergy 3 RC3 and got some error


Recommended Posts

Hi all.

I installed Synergy 3 RC3 on my notebook (Windows 11) yesterday with no problem. But today I installed the same installation file on my desktop (Windows 11) and found the error "There was a problem validating your serial key". 

I have tried to uninstall and remove anything about Synergy from my Desktop, reboot and start installation process again. However, I also found the error  "There was a problem validating your serial key".   I tried to use another option "offliine serial key", but it didn't work  (Cann't paste the serial key into the box).

So, anyone can give me the suggestion to resolve this issue.

Regards and Thanks.

xx1.png

xx2.png

Link to post
Share on other sites
Neil Carpenter

Same thing here.  Absolutely opaque error message tells me it's some sort of licensing problem:

Sentry event ID: f2b8dbc97161414aac3db60c7f181105

There was a problem with the local background service.

Quote

Error: fetch from service failed
    at /Applications/Synergy.app/Contents/Resources/app.asar/build/electron.js:2943:15
    at process.processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async node:electron/js2c/browser_init:2:97893
[cause] Error: bad response 400 from service at: settings/serial
    at createExceptionFromResponse (/Applications/Synergy.app/Contents/Resources/app.asar/build/electron.js:227:18)
    at fetchFromService (/Applications/Synergy.app/Contents/Resources/app.asar/build/electron.js:196:17)
    at process.processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async /Applications/Synergy.app/Contents/Resources/app.asar/build/electron.js:2941:18
    at async node:electron/js2c/browser_init:2:97893
[cause] Error: unable to find license with valid edition
    at SettingsRoutes.saveSerial (/snapshot/service/dist/synergy-service.js:8646:21)
    at Layer.handle [as handle_request] (/snapshot/service/node_modules/express/lib/router/layer.js:95:5)
    at next (/snapshot/service/node_modules/express/lib/router/route.js:137:13)
    at Route.dispatch (/snapshot/service/node_modules/express/lib/router/route.js:112:3)
    at Layer.handle [as handle_request] (/snapshot/service/node_modules/express/lib/router/layer.js:95:5)
    at /snapshot/service/node_modules/express/lib/router/index.js:281:22
    at Function.process_params (/snapshot/service/node_modules/express/lib/router/index.js:335:12)
    at next (/snapshot/service/node_modules/express/lib/router/index.js:275:10)
    at /snapshot/service/node_modules/body-parser/lib/read.js:130:5
    at invokeCallback (/snapshot/service/node_modules/raw-body/index.js:224:16)

And, yet, symless.com indicates:
 

Quote

You have access to Synergy 3!

Access to Synergy 3 is granted through either the Synergy or Synergy Ultimate license displayed on your account page. This is also known as your maintenance license. To use the Synergy 3 license, simply download and install Synergy 3, then enter your email and password when Synergy 3 starts. This will automatically use the correct license from your account.

So, that's 20 minutes of my morning wasted.

Link to post
Share on other sites
Neil Carpenter

Since I was already annoyed, I spent a few minutes searching in Discord to find this is a known issue from at least three days ago that nobody has fixed or documented elsewhere.  So, ahhh, Nick -- appreciate the unnecessarily wasted 25 minutes this morning.

https://discord.com/channels/672449930345971733/1009455765897101422/1161381904344424459

@Christ -- use your offline license code instead of username & password.  That worked for me.

  • Like 1
Link to post
Share on other sites

Thannk @Neil Carpenter 

I cann't input any offline license code too (normally I copied the license code from my account page and pasted to my notebook). 

I think it caused the connection of Synergy RC3 software from my PC cann't connect to the server for validation.

I also reported this issue to support team and hope that they may suggest the method to resolve that.

Regards.

Link to post
Share on other sites

I'm having the same issue. FYI pasting only works for me doing CTRL+V (right click paste not working and neither is using the paste option under edit), but even then, the serial isn't accepted. Submitted a ticket. 

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...