Jump to content

MacOS silicon M2 as client would not wake up


j2robot

Recommended Posts

Macbook Air M2 as client (with latest Synergy Apple silicon version) and Windows as server. Whenever mac goes to sleep, I couldn't wake it up with mouse/keyboard from server.

I had Macbook Pro (Intel) as client and Windows as server. This was not a problem.

Link to comment
Share on other sites

  • 2 months later...
  • Synergy Team
Daniel Evenson

Hi 👋

It might be related to macOS settings to "wake for wifi network access"

Steps:

  1. On your Mac, choose Apple menu  2f77cc85238452e25cb517130188bf99.png > System Settings, then click Battery 89871c0fe9a98c4bbe05d2665cfe3180.png in the sidebar. (You may need to scroll down.)
  2. Click Options on the right, click the pop-up menu next to Wake for network access, then choose an option
  3. Click Done.

Source - Apple KB

Link to comment
Share on other sites

  • 4 weeks later...

I just started using Synergy, and I am having the same problem, sort of. Both client and server are Mac OS Monterey (Intel). The server is an iMac and the client is a MacBook Pro. When both computers go to sleep at night, only the server responds to mouse movement and wakes up. However, while the client MBP is still sleeping, the cursor will not even move into the client machine in order to wake it. It stops at the edge of the server's screen like it would without Synergy being installed. Both machines have "wake for network access" enabled. This is a bit of a deal breaker. Luckily I still have the hardware mouse/keyboard switch installed that I was hoping Synergy would eliminate the need for, but this makes it still a very much needed device since I use the MBP in clamshell mode all of the time. I realize I could always open the lid and "wake" it but if the client were another iMac or desktop machine, this wouldn't be possible.

Link to comment
Share on other sites

  • Synergy Team
Daniel Evenson

👋 Hi Bill,

Would you mind checking adding Synergy as a login item in MacOS?  - Apple KB with instructions.

Also, if the MacBook is running in Clamshell mode, it may be related to power/battery settings - ie. perhaps that the network adapter is shutting  down.

Link to comment
Share on other sites

Hi thanks for replying. I _think_ the problem may have been related to me manually putting the machine to sleep. If I let it sleep on its own, it seems to work. I will repost here if I can confirm this.

Link to comment
Share on other sites

  • 3 weeks later...

Hi!

I was wondering if there's a solution to this. I'm also experiencing the same problems. My windows computer is the server, and my M1 MacBook is a client. Whenever it goes to sleep, I get the same problems. I have "Wake for networks access" checked, and I have it added as a login item.

Link to comment
Share on other sites

I'm experiencing this too. Windows 10 as server/primary and iMac (Intel) with macOS 12 as client. Windows wakes on mouse move, but the iMac will not wake until I press a key on the iMac keyboard. At which point Synergy works fine at the login/lock screen. Wake for network and the login item are present on the iMac.

Link to comment
Share on other sites

  • Synergy Team
Daniel Evenson

A few things to try and check:

1.Ensure that the elevated privileges under Preferences is set to Always

2. You may want to try Synergy 3 Beta, which has an option for this in the settings:
image.png.be18ef4c3d19ccf0bd50177c769fbe6e.png
 

Link to comment
Share on other sites

I should have made it clear that I am using Synergy 3 Beta. The login screen option is enabled and working well on the Mac when awake. It just won't wake a sleeping Mac. I'm not sure what you mean by step 1, or perhaps that is a v1 only option.

Edited by IT Troll
Link to comment
Share on other sites

  • Synergy Team
Daniel Evenson

Apologies, the elevated privileges setting in Synergy 1 is under Preferences:

image.png.5b02d92672ed40d0ee4fa8cf57eae14b.png

and in Synergy 3 it's under the Developer page:

image.png.95ab22b95068932cfc280fdbfb38f01b.png

 

Link to comment
Share on other sites

Quote

Apologies, the elevated privileges setting in Synergy 1 is under Preferences:

I simply do not have that - the only thing in that section is "User interface language". Is it  "pro" version option?

Screen Shot 2023-04-11 at 3.05.10 PM.png

Link to comment
Share on other sites

  • Synergy Team
Daniel Evenson
On 4/12/2023 at 10:25 PM, IT Troll said:

I do have the option in Synergy 3 and it is already enabled.

Thought to double check the settings:

1. Do you have wake for wifi access enabled on the Mac?
2. Elevated privleges set to Always
3. The allow Synergy to control at login screen is enabled?

Link to comment
Share on other sites

  • Synergy Team
Daniel Evenson
On 4/11/2023 at 8:05 PM, Bill M. said:

I simply do not have that - the only thing in that section is "User interface language". Is it  "pro" version option?

Screen Shot 2023-04-11 at 3.05.10 PM.png

I think when the Mac is set to server, that option might be set to always by default and the option is hidden. Would double check the Windows computer is option is set to Always as well.

Link to comment
Share on other sites

Interestingly, I have managed to wake my Mac using my Windows PC mouse for the past couple of days. Not sure what changed. I am Intel Mac rather than Apple Silicon though.

  1. Wake for network enabled (using Ethernet rather than Wi-Fi)
  2. Yes
  3. Yes
Edited by IT Troll
Link to comment
Share on other sites

On 4/20/2023 at 4:59 AM, Daniel Evenson said:

I think when the Mac is set to server, that option might be set to always by default and the option is hidden. Would double check the Windows computer is option is set to Always as well.

I do not have a windows machine - they are both Intel Macs. The screenshot before was the server. This one is the client, but still no options like those described. So far it's 50/50 I'd say. There just seems to be no direct relation as to why it works some times and why it doesn't other times. 

Screen Shot 2023-04-24 at 9.08.56 AM.png

Link to comment
Share on other sites

  • 2 months later...
  • 3 weeks later...

I also just got Synergy 3 RC2 and am having the same problem. I have to wake my Mac from sleep using a mouse or keyboard that's either physically connected to the computer or paired via Bluetooth--I can't wake it from my host PC.

On my Mac, the "Allow Synergy to control this computer on the login screen" option is now an "ENABLE" button instead of a switch. I'm not sure whether this means the option is already enabled, or if I need to click to enable it. However, when I try clicking it, it looks as if the app crashes and the problem remains.

916480131_Screenshot2023-07-27at9_04_03PM.png.0cc10f1c6a49189eaa3ddb29e3a3b932.png

I really hope this issue will be fixed in a future update, because when it works, Synergy is truly as seamless an experience for me as it's advertised to be, but having to switch peripherals because I can't wake my Mac through the app does impact its usefulness on a pretty regular basis.

Link to comment
Share on other sites

  • 8 months later...
McShaman

I am also having this problem on my M2 Pro Macbook Pro. Ubuntu box is my primary machine and I have my Macbook off to the side. After a while the Mac will fall asleep and I have to physically press a button on it to wake it up.

I have verified that:

  1. wake for wifi access enabled on the Mac
  2. allow Synergy to control at login screen is enabled

Regarding "Elevated privleges", this option no long seems to be available in Synergy?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...