Jump to content
Get SynergyOpen a support ticket

Mouse jumping back to Server Machine

Recommended Posts



im running Synergy 1.14.3-stable on my Windows 10 as Server and
1.10.3-3 on my Arch Linux as a Client. Typing Characters like Backspace or Arrow Left, Right, Up, Down sometimes makes the Mouse jump back to Server (also focus).

This is the Message i get on the Client Machine:

2022-04-27T15:03:48] DEBUG1: mapped to 071, new state 2000

[2022-04-27T15:03:48] DEBUG1: keystrokes:

[2022-04-27T15:03:48] DEBUG1: 071 (00000000) up

[2022-04-27T15:03:48] DEBUG1: 071 (00000000) down

[2022-04-27T15:03:48] INFO: leaving screen

[2022-04-27T15:03:48] DEBUG1: keystrokes:

[2022-04-27T15:03:48] DEBUG1: 071 (00000000) up

[2022-04-27T15:03:48] DEBUG: Closing socket: 0F77FBA0

[2022-04-27T15:03:48] DEBUG: retry in 1 seconds

[2022-04-27T15:03:48] ERROR: invalid message from server:

[2022-04-27T15:03:48] WARNING: failed to connect to server: invalid message from server

[2022-04-27T15:03:49] NOTE: connecting to '':

[2022-04-27T15:03:49] DEBUG: Opening new socket: 0F7B00A0

[2022-04-27T15:03:49] DEBUG1: connecting to server

[2022-04-27T15:03:49] DEBUG1: connected; wait for hello

[2022-04-27T15:03:49] DEBUG1: got hello version 1.8

[2022-04-27T15:03:49] DEBUG1: say hello version 1.6

[2022-04-27T15:03:49] DEBUG1: sending info shape=0,0 1921x2160

[2022-04-27T15:03:49] DEBUG1: recv info acknowledgment

[2022-04-27T15:03:49] DEBUG1: recv reset options


This is the Log on Server at the same time:


[2022-04-27T15:14:38] DEBUG1: hook: 0x07270000 0x014d0001
[2022-04-27T15:14:38] DEBUG1: event: Key char=0, vk=0x27, nagr=0, lParam=0x014d0001
[2022-04-27T15:14:38] DEBUG1: new mask: 0x2000
[2022-04-27T15:14:38] DEBUG1: new mask: 0x2000
[2022-04-27T15:14:38] DEBUG1: onKeyRepeat id=61267 mask=0x2000 count=1 button=0x014d lang="de"
[2022-04-27T15:14:38] DEBUG1: hook: 0x00000027 0x814d0001
[2022-04-27T15:14:38] DEBUG1: hook: 0x60270000 0x814d0001
[2022-04-27T15:14:38] DEBUG1: hook: 0x07270000 0x814d0001
[2022-04-27T15:14:38] DEBUG1: event: Key char=0, vk=0x27, nagr=0, lParam=0x814d0001
[2022-04-27T15:14:38] DEBUG1: new mask: 0x2000
[2022-04-27T15:14:38] DEBUG1: new mask: 0x2000
[2022-04-27T15:14:38] DEBUG1: onKeyUp id=61267 mask=0x2000 button=0x014d
[2022-04-27T15:14:39] DEBUG: Opening new socket: AB669C40
[2022-04-27T15:14:39] NOTE: accepted client connection
[2022-04-27T15:14:39] DEBUG1: saying hello
[2022-04-27T15:14:39] DEBUG1: parsing hello reply
[2022-04-27T15:14:39] DEBUG1: querying client "neuromancer" info
[2022-04-27T15:14:39] DEBUG1: created proxy for client "neuromancer" version 1.6
[2022-04-27T15:14:39] DEBUG: received client "neuromancer" info shape=0,0 1921x2160 at 960,540
[2022-04-27T15:14:39] DEBUG1: send info ack to "neuromancer"
[2022-04-27T15:14:39] DEBUG: active sides: 14
[2022-04-27T15:14:39] NOTE: client "neuromancer" has connected
[2022-04-27T15:14:39] DEBUG1: send reset options to "neuromancer"
[2022-04-27T15:14:39] DEBUG1: send set options to "neuromancer" size=26
[2022-04-27T15:14:39] DEBUG1: hook: 0x00000027 0x014d0001
[2022-04-27T15:14:39] DEBUG1: hook: 0x60270000 0x014d0001
[2022-04-27T15:14:39] DEBUG1: hook: 0x07270000 0x014d0001


Any Ideas?


Link to post
Share on other sites
  • 3 weeks later...

I'm having the same issue. It happens every time I hold down the backspace button, but it also happens other times as well.

Link to post
Share on other sites
  • 5 months later...

This is bulls_hit man! - I had this symptom some time ago - and yeah - making sure client and server were the same version fixed it for me - until now...

Client : Running 1.14.5-stable on MacOS Monterey 12.6.1 (MacBook Pro M1)

Server : Running 1.14.5-stable on Ubuntu 22.04 (Ryzen 7, crippled by X11 [yes I resent being unable to run Wayland!])

Now it keeps happening - only the Mac on the right of my server running on Linux.  I have a near identical MacBook pro running on the Left and it NEVER happens there!

Its DAMN annoying - I do most of my work in shells, often remote - and - I touch type, and suddenly - the stuff I'm typing into iTerm2 on the MacBook on the right, starts being typed in my server in WHATEVER app happens to be the focus...  Could be a browser, a text editor, another terminal...

Link to post
Share on other sites
  • 2 weeks later...

Same here. It started last week and now it's totally unpredictable. 

It's infuriating. 

I've updated both to 1.14.6 versions and I'm running two macs on MacOS 12.6.1 and neither have been updated recently. I have also rebooted them, the wifi router... everything. And the mouse is a perfectly functioning 3 month old magic mouse. 

Nothing seems to solve the problem and I am definitely not holding any key down and I can't even see anything wrong with the logs.

Has anyone found a way to solve this?

  • Like 1
Link to post
Share on other sites

This is NOT solved for me - my "workaround" was to re-jig re-arrange my devices and monitors.

This symptom was ONLY happening with the device on the "Right" (it NEVER happened with the client on the far left) - which was a MacBook Pro.

I've moved that MacBook to the middle (and it's the server) and the device on the right is now a Linux desktop machine - and I no longer experience this symptom - however it's annoying knowing this can STILL HAPPEN!

@RafaSoares - if ALL your machines are Macs - I'd suggest using Universal Control - I'm using BOTH Universal Control between Macs, and Synergy server on one Mac, and synergy client on Linux Ubuntu 22 on the right...


Link to post
Share on other sites

Same thing had been happening to me for months - the amount of times the cursor would jump back to the server appeared to be random. As of yesterday I fixed the problem by reinstalling Synergy on both the windows server and mac client. Nothing else about the setup has changed. 

Link to post
Share on other sites
  • 2 weeks later...

This happens on my three machines too. Server is Win11. I had the server on MacOS but thought if I moved it to Windows, the jumping would stop. It didn't. I can't correlate when it randomly happens (or freezes). The only times I can correlate is when running any Windows app that will change system settings which give me a dialog approval popup window. When that happens either on the server or the second Windows laptop, the cursor and focus will jump to the top left of the Windows machine acting as the Symless server.

Link to post
Share on other sites

Note : it's happening again to me - stopped using Universal Control (because it's EXTREMELY unreliable - when it works it's SEAMLESS, but nearly every time I go to use it - it's STOPPED!  FIX THIS APPLE! I actually spent $300 to get a Magic Keyboard and Magic Trackpad 2 so I could use Universial control between 2 Macs) - My setup is Leftmost : MacBook Pro M1, Middle (server) MacBook Pro M1, Right Ubuntu 22.04 (Ryzen 7) - and sometimes - Far Right Bottom - Thinkpad E495 Ryzen 5 Ubuntu 22.10.

Can't attribute any rhyme or reason to when it happens, but it really jacks me off when it does - i.e. I'm typing away in a terminal or text editor on the "first right" client machine (Ryzen 7 Ubuntu 22.04) - and then suddenly I'm typing away in whatever window is active on the Server (MacOS 12.6.1) - in some previous iteration of Synergy, this used to happen when holding down e.g. backspace - but not this time...   Something else is triggering it.

Frustrating to say the least!

Edited by UnixOutlaw
added another machine
Link to post
Share on other sites
  • 3 weeks later...

STILL HAPPENING, still only 1.14.6 available!

Some earlier iteration of 1.14 fixed this bug, then some other iteration (1.14.5?  1.14.6?) re-introduced it...

Link to post
Share on other sites
  • 1 month later...


Now (moved server over to Linux) 

Left (client) MacOS 12.6 MBP M1

Middle (client) MacOS 12.6 MBP M1

Right (server) Ubuntu 22.04 Ryzen 7 32 GB RAM NVMe SSD, AMD GPU (Radeon)

I don't know if it was Synergy client doing it or not - but I kept getting cases when Linux was the client (on the right) that CTRL, or ALT or SHIFT keys were stuck ON and couldn't be "unstuck" (no sticky keys is NOT enabled in Accessibility) - so I made the Linux box the server - but now I'm getting it jumping back to the Linux machine from the middle MacOS client...


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...