Jump to content
Get SynergyOpen a support ticket

Libssl1.1 error on Ubuntu 22.04


Recommended Posts

Appears that Libssl1.1 has been deprecated in 22.04 in favour of Libssl3. You're going to need to update your dependencies in Synergy 1 for a 22 release.

Confirmed workaround here from spotify if anyone is looking for a way to get the 21 release going: https://community.spotify.com/t5/Desktop-Linux/Ubuntu-22-04-spotify-client-depends-on-nonexistent-libssl1-1/td-p/5365455

Link to post
Share on other sites
lemketron

I had to install libssl1.1 as well as qt (since qt5-default is also now missing):

wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1l-1ubuntu1.2_amd64.deb
sudo dpkg -i libssl1.1_1.1.1l-1ubuntu1.2_amd64.deb
sudo apt-get install qtbase5-dev qtchooser qt5-qmake qtbase5-dev-tools
sudo dpkg -i synergy_1.14.3-stable.218fa800_ubuntu21_amd64.deb

 

Link to post
Share on other sites
Whoops

We need a new release built against libssl3

ubuntu-22.04 LTS has released 

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...