Jump to content
Get SynergyOpen a support ticket

Debian 9 install fails with dependencies to debian 10 libs?


Recommended Posts

Tsarsov

[email protected]: ~ $ cat /etc/os-release 
PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
(system updated/upgraded 4/12/2022)

 

[email protected]:~# dpkg -i ./synergy_1.14.3-stable.218fa800_debian9_amd64.deb 
Selecting previously unselected package synergy.
(Reading database ... 130428 files and directories currently installed.)
Preparing to unpack .../synergy_1.14.3-stable.218fa800_debian9_amd64.deb ...
Unpacking synergy (1.14.3.stable.218fa800) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.11.0~rc1); however:
  Version of libqt5core5a:amd64 on system is 5.7.1+dfsg-3+deb9u3.
 synergy depends on libqt5widgets5 (>= 5.11.0~rc1); however:
  Version of libqt5widgets5:amd64 on system is 5.7.1+dfsg-3+deb9u3.
 

lookup one of the libs: https://packages.debian.org/search?keywords=libqt5core5a

  • stretch (oldoldstable) (libs): Qt 5 core module
    5.7.1+dfsg-3+deb9u3 [security]: amd64 arm64 armel armhf i386
    5.7.1+dfsg-3+deb9u2: mips mips64el mipsel ppc64el s390x
  • buster (oldstable) (libs): Qt 5 core module
    5.11.3+dfsg1-1+deb10u4: amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64el s390x

looks like buster has the 5.11 update, not stretch.   Or did I miss something?

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...