Jump to content
Get SynergyOpen a support ticket

Problem installing on 21.04 ubuntu


Recommended Posts

jrborden

Hello,

I'm trying to install Synergy v1.14-stable on Ubuntu 21.04.  I'm having a dependency issue I cannot resolve however.  Here's the output I'm getting...

$ sudo dpkg -i ./synergy_1.14.0-stable.67d824b8_ubuntu20_amd64.deb
(Reading database ... 296426 files and directories currently installed.)
Preparing to unpack .../synergy_1.14.0-stable.67d824b8_ubuntu20_amd64.deb ...
Unpacking synergy (1.14.0.stable.67d824b8) over (1.14.0.rc.479ee15a) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2); however:
  Package libqt5gui5:amd64 is not installed.
  Package libqt5gui5-gles is not installed.
 synergy depends on libqt5network5 (>= 5.0.2); however:
  Package libqt5network5 is not installed.
 synergy depends on libqt5widgets5 (>= 5.11.0~rc1); however:
  Package libqt5widgets5 is not installed.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.26-1ubuntu1) ...
Processing triggers for mailcap (3.68ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 synergy

Any advice on how to proceed would be greatly appreciated.

- jb

 

 

 

Link to post
Share on other sites
Malware
Posted (edited)

It's been a while since I've used Ubuntu (you should check out Manjaro) but it seems like the following command might be the most reasonable place to start....

sudo apt-get install -y libqt5gui5 && 

sudo apt-get install -y libqt5gui5 && \
sudo dpkg -i ./synergy_1.14.0-stable.67d824b8_ubuntu20_amd64.deb

 

Edited by Malware
double
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...