Jump to content
Get SynergyOpen a support ticket

I just installed Synergy on BigSur M1 Mac mini and it keeps forgetting my activation serial.


Recommended Posts

Rootspear

I had the same problem. On my main Mac (server), the activation was remembered. On the client Mac it was not.

How I fixed this  was to manually save the configuration. Synergy > Save configuration as. It then "remembered" on the next boot!!! 

Link to post
Share on other sites
A3igner
18 minutes ago, Rootspear said:

I had the same problem. On my main Mac (server), the activation was remembered. On the client Mac it was not.

How I fixed this  was to manually save the configuration. Synergy > Save configuration as. It then "remembered" on the next boot!!! 

I thought this would solve it as well. But even if you tick Auto-Config it keeps forgetting it on both the client and server. 

this is for latest BigSur. 

Edited by A3igner
Typo
  • Thanks 1
Link to post
Share on other sites
Rootspear

I don't know what to say... I've tried out Symless off / on for the best part of a decade and each time I've sought solutions elsewhere after a brief stint, because there's always been some faff with Synergy. Till now that is! It's far from perfect, but I'm faff-free and it suffices for my simple needs this time.

The activation scenario is very tiresome, I hope someone will come along with a solution for you guys. 

FYI: auto configuration refused to work for me, both on client and server....

 

 

Link to post
Share on other sites
A3igner
28 minutes ago, Rootspear said:

I don't know what to say... I've tried out Symless off / on for the best part of a decade and each time I've sought solutions elsewhere after a brief stint, because there's always been some faff with Synergy. Till now that is! It's far from perfect, but I'm faff-free and it suffices for my simple needs this time.

The activation scenario is very tiresome, I hope someone will come along with a solution for you guys. 

FYI: auto configuration refused to work for me, both on client and server....

 

 

I am not going to use this software even though it works nicely between monitors once its up and running. I will revisit it again later when they have fixed these two issues.  (1) autostart server (2) auto activate/sticky activation. In the meantime a simple USB switch for 15$ will suffice.

Link to post
Share on other sites
  • Synergy Team
Kimberly

We have found a work around that just might help you with this: 

1. Activate Synergy.

2. Go to Synergy tab on the top left corner of your mac.

3. Quit

4. Save for the user.

5. Run and Test.

Please let us know if this works for you. 

Link to post
Share on other sites

I fixed it by changing the configuration from “system” to “user” I think it was. I’m not looking at it right now but after that it saved. 

Link to post
Share on other sites
A3igner
2 hours ago, Kimberly said:

We have found a work around that just might help you with this: 

1. Activate Synergy.

2. Go to Synergy tab on the top left corner of your mac.

3. Quit

4. Save for the user.

5. Run and Test.

Please let us know if this works for you. 

Thanks i will try it out.   It seems to have remembered the key now. I will test it tomorrow morning.

How can i make it autostart on Mac? Add it to the Startup Apps for the User in Mac Preferences?

Link to post
Share on other sites
A3igner
13 hours ago, Kimberly said:

We have found a work around that just might help you with this: 

1. Activate Synergy.

2. Go to Synergy tab on the top left corner of your mac.

3. Quit

4. Save for the user.

5. Run and Test.

Please let us know if this works for you. 

Great! I can confirm that for Big Sur 11.1 on a Mac Mini (M1, 2020) this works and saves the serial key.

After you add the App to the Login Items for the User it starts up automatically for both server and client on both machines.

If i switch the client machine to auto-login then i can do away with a second keyboard on that machine.
Ideally you would want it to run as a root service already before login of a user. But your colleague said you are working on that.

This is good enough for me for now!

So Thank You Kimberly!

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...