Jump to content

Hello! ūüĎč

Our forums have moved to: discourse.symless.com

These forums are now archived (read only).

can't install on Deepin OS (based on Debian/Ubuntu)


Recommended Posts

hello,

+ I had synergy 1.11.1 on Deepin OS 

+ I uninstalled it to install the newer version

+ I can't install the new  version

I use this procedure:

1) sudo dpkg -i synergy_1.12.0.stable_b20200827.1+cb8064e8_ubuntu20_amd64.deb

2) sudo apt -f install

 

1 gives:

(Reading database ... 207271 files and directories currently installed.)
Preparing to unpack synergy_1.12.0.stable_b20200827.1+cb8064e8_ubuntu20_amd64.deb ...
Unpacking synergy (1.12.0.stable~b20200827.1+cb8064e8) over (1.12.0.stable~b20200827.1+cb8064e8) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libgcc-s1 (>= 3.0); however:
  Package libgcc-s1 is not installed.
 synergy depends on libqt5core5a (>= 5.12.2); however:
  Version of libqt5core5a:amd64 on system is 5.7.1+dfsg-10deepin.
 synergy depends on libqt5widgets5 (>= 5.11.0~rc1); however:
  Version of libqt5widgets5:amd64 on system is 5.7.1+dfsg-10deepin.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured
Processing triggers for lastore-daemon (0.14.6-1+comsta) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for bamfdaemon (0.5.3-2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.60) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Errors were encountered while processing:
 synergy

2 gives

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  synergy
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 4,022 kB disk space will be freed.
Do you want to continue? [Y/n] 

 

Link to post
Share on other sites

I don't know what I did... it seems like I screwed everything up!! please help!

if I do: $ sudo apt -f install

I get this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  krita-data libexiv2-14 libgsl2 libkf5bookmarks-data libkf5kdelibs4support-data libkf5parts-data libopencolorio1v5 libtinyxml2.6.2v5 libyaml-cpp0.3v5
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libutempter0 xbitmaps xterm
Suggested packages:
  xfonts-cyrillic
The following packages will be REMOVED:
  dde dde-calendar dde-control-center dde-daemon dde-desktop dde-disk-mount-plugin dde-dock dde-dock-onboard-plugin dde-file-manager dde-introduction dde-kwin
  dde-launcher dde-polkit-agent dde-qt5integration dde-session-ui deepin-anything-server deepin-appstore deepin-calculator deepin-cloud-scanner deepin-deb-installer
  deepin-deepinid-client deepin-editor deepin-feedback deepin-font-installer deepin-graphics-driver-manager deepin-image-viewer deepin-manual deepin-menu
  deepin-movie deepin-music deepin-screen-recorder deepin-screensaver deepin-screensaver-xscreensaver-data deepin-screenshot deepin-shortcut-viewer
  deepin-system-monitor deepin-terminal deepin-turbo-booster deepin-voice-recorder dpa-ext-gnomekeyring kio kolourpaint4 kpackagetool5 krita kwin-common kwin-x11
  libdbusmenu-qt5-2 libdde-file-manager libdde-network-utils libdeepin-font-installer libdframeworkdbus2 libdisomaster libdmr libdtkcore2 libdtkwidget2 libdtkwm2
  libgsettings-qt1 libkdecorations2-5v5 libkdecorations2private5v5 libkf5activities5 libkf5archive5 libkf5attica5 libkf5auth5 libkf5bookmarks5 libkf5calendarevents5
  libkf5codecs5 libkf5completion5 libkf5configcore5 libkf5configgui5 libkf5configwidgets5 libkf5coreaddons5 libkf5crash5 libkf5dbusaddons5 libkf5declarative5
  libkf5globalaccel-bin libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n5 libkf5iconthemes5 libkf5idletime5 libkf5itemviews5
  libkf5jobwidgets5 libkf5kcmutils5 libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiontlm5 libkf5kiowidgets5
  libkf5networkmanagerqt6 libkf5newstuff5 libkf5notifications5 libkf5package5 libkf5parts-plugins libkf5parts5 libkf5plasma5 libkf5plasmaquick5 libkf5quickaddons5
  libkf5service-bin libkf5service5 libkf5solid5 libkf5sonnetcore5 libkf5sonnetui5 libkf5syntaxhighlighting5 libkf5textwidgets5 libkf5wallet-bin libkf5wallet5
  libkf5waylandclient5 libkf5waylandserver5 libkf5widgetsaddons5 libkf5windowsystem5 libkf5xmlgui5 libkscreenlocker5 libkwalletbackend5-5 libkwin4-effect-builtins1
  libkwineffects9 libkwinglutils9 libkwinxrenderutils9 liblightdm-qt5-3-0 libphonon4qt5-4 libpolkit-qt5-1-1 libpoppler-qt5-1 libqapt3 libqapt3-runtime libqcef1
  libqgsttools-p1 libqt5clucene5 libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5designer5 libqt5gui5 libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins
  libqt5multimediaquick-p5 libqt5multimediawidgets5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5quickcontrols2-5
  libqt5quicktemplates2-5 libqt5quickwidgets5 libqt5script5 libqt5sql5 libqt5sql5-sqlite libqt5svg5 libqt5test5 libqt5webchannel5 libqt5widgets5 libqt5x11extras5
  libqt5xdg3 libqt5xdgiconloader3 libqt5xml5 libsane-drs libthrift-0.10.0 libudisks2-qt5 phonon4qt5 phonon4qt5-backend-vlc plasma-framework
  printer-driver-deepin-cloud-print python3-pyqt5 qdbus-qt5 qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-qtgraphicaleffects
  qml-module-qtmultimedia qml-module-qtquick-controls qml-module-qtquick-controls2 qml-module-qtquick-layouts qml-module-qtquick-templates2
  qml-module-qtquick-window2 qml-module-qtquick2 qpdfview qpdfview-djvu-plugin qpdfview-ps-plugin qt5-image-formats-plugins qt5dxcb-plugin startdde synergy
The following NEW packages will be installed:
  libutempter0 xbitmaps xterm
0 upgraded, 3 newly installed, 183 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 703 kB of archives.
After this operation, 794 MB disk space will be freed.
Do you want to continue? [Y/n] n                                                                                                 
Abort.


 

Link to post
Share on other sites

please note that my OS needs certain Qt modules, while Synergy wants newer modules. I think (part of?) the problem is that the OS doesn't work with newer modules.

if I use above method to install some newer Qt modules (from .deb file), I get the above message in post 2 which messes up the system

Edited by wajed
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...