Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Request: OpenSuSE 15.1+ compatability


Recommended Posts

Hi,

I used to use Synergy 1 on OpenSuSE and it was great. I had 3 monitors on my desktop split across an OpenSuSE server and MacOS client, (local access only) so finding Synergy was a  godsend

I used to install Synergy via the RPM file using the zypper command whilst ignoring the errors regarding xscreensaver not being present. I had to create some symbolic links for libssl (e.g., libssl.so.10) , but never had a problem with it actually running.

When I upgraded to OpenSuSE 15 I lost the ability to use Synergy completely. libcrypto is not available at all,from the default repos, and the libssl version installed was higher than the version actually required. Nothing I could do would make the app actually run in any way shape or form.

Please make the library requirements a bit more sensible. Make the version numbers a "minimum" rather than an "exact" match. I would imagine that version 1.1.0 of libssl has the same methods available as 1.0.2j etc. If a local connection is all that's required and the relevant ports are not open to the outside world, could the encryption optional be optional?

 

Link to post
Share on other sites
  • 1 month later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...