Jump to content

Hello! šŸ‘‹

Our forums have moved to: discourse.symless.com

These forums are now archived (read only).

"you have not filled in a valid configuration file for the synergy server"


Recommended Posts

UnixOutlaw

I get this on a client machine (Ubuntu 18.04) EVERY SINGLE time I start it :Ā 

You have not filled in a valid configuration file for the synergy server.Ā  Do want to browse for the configuration file now?

5d99bb2f02ea1_Screenshotfrom2019-10-0617-58-33.png.9b60cedc29ad6732db0c17d6ffbaf84c.png

My serverĀ machine is Ubuntu 19.04.

All are running the latest 1.10.3 - specifically the 1.10.3 deb file for 19.04 on the server, and the specifically 1.10.3 deb file for 18.04 on the client.Ā  This message is not very helpful, because I'm not running this machine as a server!

This was happening on the previous version I was running on the same client machine too (don't remember the exact version - but it was a 1.10.x version)...

I've tried purging it (sudo apt purge synergy, then re-installing from the deb file with dpkg) and this still happens.

I've tried setting it to "auto" - but that doesn't work either (it removes the above message on start - but never finds an auto config from a server - and the pull down box for the auto server entry is "empty"...

This is fully licensed Synergy Pro...

5d99bda44d061_Screenshotfrom2019-10-0618-05-47.png.d8a756140df5b084105ac20c82ed6f42.png

Soon as I click on the "No" button - it goes ahead and fires up the client.

It's frustrating because it looks "broken"... sure it works - but it's an annoyance given that it's software I've paid for...

Link to post
Share on other sites
Jamie Newbon

Hi

I have seen this before and IĀ believe looking at your screenshots that the particular machine has been set to use a custom configuration as the server then was switched to a client.

You can fix this by switching it to server mode and then selecting "configure interactively" and then switching back to client mode.

The software still uses configs when in client mode but it shouldn't be related to server-side config settings.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...