Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

I Can't Change new server on Mac OS


Recommended Posts

maxasus123

Hi, 

plz help me.

I Can't Change new server on Mac OS

I install Synergy on linux ubuntu 18.04 use server 

 

Screen Shot 2562-06-04 at 17.14.06.png

Link to post
Share on other sites
Jamie Newbon

Synergy uses Bonjour for auto configuration, and currently Linux auto config as a server doesn't broadcast itself to clients.

What you can do is in the top left click on [Synergy]->[Preferences] and uncheck 'Enable Auto Config'

That will allow you to type in the servers IP address manually

Link to post
Share on other sites
  • 9 months later...
On 6/4/2019 at 10:15 AM, Jamie Newbon said:

Synergy uses Bonjour for auto configuration, and currently Linux auto config as a server doesn't broadcast itself to clients.

What you can do is in the top left click on [Synergy]->[Preferences] and uncheck 'Enable Auto Config'

That will allow you to type in the servers IP address manually

Hi Jamie,

 

 I tried this exact approach with the latest version of Synergy on Mac OS Catalina, and I was met with unsuccessful results. The desktop client interface did not change at all and still would not allow me to enter an IP address.
 

Screen Shot 2020-03-20 at 1.33.48 PM.png

  • Like 1
Link to post
Share on other sites

If you uncheck the auto-config option as mentioned previously, there are a couple more steps:

1) Stop the synergy client
2) Completely quit the Synergy app (kill it - there should be no synergy processes running at all)
3) Now start synergy and try - it did let me enter my IP address. I'm on Catalina as well.

Regards,
KASL

Link to post
Share on other sites
itsgarrett

Unchecking auto-config and restarting did not change the behavior for me.

What did work, was closing Synergy, right-click the Synergy app and select Open. Now I can enter the server address.

Link to post
Share on other sites

 

2 hours ago, itsgarrett said:

Unchecking auto-config and restarting did not change the behavior for me.

What did work, was closing Synergy, right-click the Synergy app and select Open. Now I can enter the server address.

Funny how we posted the solution just moments apart... 

Link to post
Share on other sites
  • 2 months later...

It's worth noting I ran into this same issue on Ubuntu 18.04 LTS just now.  Unchecking "Enable Auto Config" in settings and then restarting did the trick.

Link to post
Share on other sites
  • 1 month later...

Agree with KASL and Mike H.

After disabling auto config, it is necessary to restart synergy. Only when this has been done can a server IP address be entered. 

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...