Jump to content

Hotkey Not Sending to Client


jrkohlmeyer

Recommended Posts

Hello everyone,

I've been using Synergy 1 Basic for a couple months now and have been loving it. Today I tried to dabble a bit into hotkeys but couldn't seem to get it to work.

For this, let's call my server PC1, and my client PC2. I want to create a hotkey that sends mouse button 3 (clicking the mouse wheel) from PC1 to PC2 as keystroke F12. I used the hotkey tab within server configuration to create just that. Hotkey: mousebutton(3), Actions: keystroke(F12,PC2).

However, when I okay the server configuration and apply the changes to synergy, even restarting my PCs just to be safe, the hotkey does not appear to work. I tried clicking mouse button 3 on both PCs just to see if I mapped it wrong, but that didn't seem to do anything. I tried changing mouse button 3 to a regular keystroke such as "q". Still no luck. Even tried saving my configuration file and editing it manually, mousebutton(3) = keystroke(F12,PC2).

Any thoughts or suggestions? Thanks for the help ahead of time!

Link to comment
Share on other sites

Update: Kind of weird, but I've somewhat figured out the issue? When I create the hotkey, Synergy is definitely registering the middle mouse wheel click as mouse button 3. However, when actually put to practice, it's sending a mouse button 2 (right mouse click) to PC2...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...