Jump to content

ssl error occured / eof violates ssl protocol

Bobby Thompson

Recommended Posts

Bobby Thompson

I just finished upgrading my 2 Macs to Mojave, both of which connect to a Windows 10 server.

One Mac upgraded with no issues, the other has not worked since the upgrade.

The server shows the following in the log for the one it won't connect to:

[2018-10-10T10:49:34] INFO: OpenSSL 1.0.2o 27 Mar 2018

[2018-10-10T10:49:34] ERROR: ssl error occurred (system call failure)

[2018-10-10T10:49:34] ERROR: eof violates ssl protocol

[2018-10-10T10:49:34] ERROR: failed to accept secure socket

[2018-10-10T10:49:34] INFO: client connection may not be secure

Over and over and over again.

The client appears to be in a loop, as I notice the start button changes to stop then start then stop (it took several clicks to actually get it to fully stop as it seemed every time I clicked the button was back to being the start button).

The client log doesn't give much of anything in the log other than:

Started client

Connecting to '...'

Stopping synergy desktop process

Process existed with error code: 9


So far I tried removing & re-adding the system entry under Configure Server, and I did a a clean re-install:



Again, only 1 Mac is doing this, the other worked without a problem.

Link to comment
Share on other sites

I upgraded to Mojave last night and I am seeing I think the same issue. 

The messages posted are what I get on the Server side.

It looks like the client is continually restarting.  These are the messages I get from the Mac Client log level Debug turned on:

[2018-10-11T10:43:50] INFO: detected process not running, auto restarting

[2018-10-11T10:43:51] DEBUG: starting process

[2018-10-11T10:43:51] INFO: starting client

[2018-10-11T10:43:51] INFO: command: /Applications/Synergy.app/Contents/MacOS/synergyc -f --no-tray --debug DEBUG --name wolverine --enable-drag-drop --enable-crypto

[2018-10-11T10:43:51] INFO: config file: /var/folders/bz/h5t0ftjd60d30jfdv38y8y4w0000gn/T/Synergy.rW4640

[2018-10-11T10:43:51] INFO: log level: DEBUG

[2018-10-11T10:43:51] INFO: drag and drop enabled

[2018-10-11T10:43:51] DEBUG: screen shape: center=0,0 size=4000x1440 on 2 displays

[2018-10-11T10:43:51] DEBUG: starting watchSystemPowerThread

[2018-10-11T10:43:51] DEBUG: adopting new buffer

[2018-10-11T10:43:51] DEBUG: opened display

[2018-10-11T10:43:51] NOTE: started client

[2018-10-11T10:43:51] DEBUG: started watchSystemPowerThread

[2018-10-11T10:43:51] DEBUG: waiting for event loop

[2018-10-11T10:43:51] NOTE: connecting to '':

[2018-10-11T10:43:51] INFO: OpenSSL 1.0.2o 27 Mar 2018

[2018-10-11T10:43:51] DEBUG: waiting for carbon loop

[2018-10-11T10:43:51] DEBUG: event queue is ready

[2018-10-11T10:43:51] DEBUG: add pending events to buffer

[2018-10-11T10:43:51] DEBUG: signalling carbon loop ready

[2018-10-11T10:43:51] DEBUG: starting carbon loop

[2018-10-11T10:43:51] DEBUG: carbon loop ready

2018-10-11 10:43:51.798 synergyc[4893:295843] starting cocoa loop

[2018-10-11T10:43:51] NOTE: server fingerprint: 1D:C4:E4:B8:2F:9C:ED:BD:C3:22:2A:39:E7:C9:BE:2F:4A:ED:5B:24

[2018-10-11T10:43:51] WARNING: cursor may not be visible

[2018-10-11T10:43:51] ERROR: failed to create quartz event tap

[2018-10-11T10:43:51] INFO: connected to secure socket

[2018-10-11T10:43:51] INFO: server ssl certificate info: /CN=Synergy

[2018-10-11T10:43:51] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD

[2018-10-11T10:43:51] DEBUG: hiding cursor

[2018-10-11T10:43:52] ERROR: process exited with error code: 11

My config is:

Linux Mint Cinnamon 19 with Synergy 1.10.0-stable-275cdc1c build

MacBook Air Mojave with the same Synergy 1.10 build version

I haven't figured out a work around yet, but if anyone else does I am all ears.  

Link to comment
Share on other sites


I got it working based on a thread that has been going for a while since the Mojave Developer Betas started in June.  

This is what I tried first and it worked on my system: 

System Preferences -> Security & Privacy -> Privacy Tab -> Accessibility Section  -> Unchecked Synergy

I started synergy It asked for permissions and I re-checked the box and now all is working.

Edited by supersickle
  • Thanks 1
Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...