Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Synergy 1.10 Dependencies for Ubuntu Distro


BzowK

Recommended Posts

Hey Guys - 

I was planning to update my installation of Synergy in Ubunutu this morning to 1.10.x when I found that there were some dependencies not met - libqt5core5a (>= 5.7.0) & libssl1.1 (>= 1.1.0).  These packages are in my OS's repos, but not the versions needed.  I proceeded to download DEBs for those two packages, but found they had dependencies so got DEBs for those and found they too had dependencies!

My primary question is: is there a repo I can add, package to install, or whatever in order to install all libraries for a a version like 5.7.1?  I see the full download for QT5 *(which I'm not that familiar with)* is 1.2gb - surely that whole thing isn't needed for a few grouped dependencies.  Below is what I encountered this morning...

**Example**
One of the two needed dependencies for the DEB I was installing was libqt5core5a 5.7.1 and the OS's repo didn't have that version so found it's DEB, downloaded, and installed it.  However, I found that with it, other dependencies were required which were libqt5gui5 (>= 5.0.2), libqt5network5 (>= 5.0.2), & libqt5widgets5 (>= 5.2.0~alpha1).  These versions also weren't in my repos, so again had to download their debs and install.  When installing them, I was prompted for more dependencies (yes, dependency of a dependency, or a dependency) which is when I decided to post. 

Any suggestions?  It sure would be helpful if there was a repo we could add to sources.list to install updates and dependencies.  Thanks!

Link to comment
Share on other sites

smokebanshee

Hello, I've had the same problem. After learning that Synergy 2 is back in beta and the problems I was having there mightn't be addressed soon, I tried to go back to Synergy 1, and I'm getting the same dependency errors (Ubuntu 16.04):
 

Preparing to unpack synergy_1.10.0.stable_b36+275cdc1c_debian_amd64.deb ...
Unpacking synergy (1.10.0.stable~b36+275cdc1c) ...
dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.7.0); however:
  Version of libqt5core5a:amd64 on system is 5.5.1+dfsg-16ubuntu7.5.
 synergy depends on libssl1.1 (>= 1.1.0); however:
  Package libssl1.1 is not installed.

dpkg: error processing package synergy (--install):
 dependency problems - leaving unconfigured

 

Link to comment
Share on other sites

smokebanshee

Worth noting that some other users appear to have gotten around this by going the compilation route:

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...