Jump to content
Get SynergyOpen a support ticket

Synergy 2 on Linux Can't Send Profile Snapshot


Recommended Posts

Sean12312
[ Service ] [2018-07-16T15:34:41] info: Session monitor stopped
[ Service ] [2018-07-16T15:34:41] debug: ignoring core process shutdown request, core is not running
[ Service ] [2018-07-16T15:34:41] debug: ignoring core process shutdown request, core is not running
[ Service ] [2018-07-16T15:34:41] debug: ignoring core process shutdown request, core is not running
[ Service ] [2018-07-16T15:34:41] debug: service log file path: /var/log/synergy/synergy-service.log
[ Service ] [2018-07-16T15:34:41] debug: install dir: /usr/bin
[ Service ] [2018-07-16T15:34:41] info: starting service...
[ Router  ] [2018-07-16T15:34:41] debug: binding to 0.0.0.0:24802
[ Router  ] [2018-07-16T15:34:41] debug: Initialized
[ Service ] [2018-07-16T15:34:41] debug: setting core uid from config: 1000
[ Service ] [2018-07-16T15:34:41] info: Session monitor started
[ Service ] [2018-07-16T15:34:41] info: Active X session changed from "--" to "c2"
[ Service ] [2018-07-16T15:34:41] info: Active X session user changed from "--" to "1000"
[ Service ] [2018-07-16T15:34:41] info: Active X session display changed from "--" to ":0"
[ Service ] [2018-07-16T15:34:41] debug: creating rpc endpoints
[ Service ] [2018-07-16T15:34:41] debug: rpc endpoints created
[ Config  ] [2018-07-16T15:34:49] debug: connected to background service
[ Config  ] [2018-07-16T15:34:49] debug: sending uid to service: 1000
[ Service ] [2018-07-16T15:34:49] debug: setting core uid from rpc: 1000
[ Config  ] [2018-07-16T15:34:49] debug: saying hello to background service
[ Service ] [2018-07-16T15:34:49] debug: saying hello to config ui
[ Service ] [2018-07-16T15:34:49] info: Tray process connected
[ Config  ] [2018-07-16T15:34:49] debug: new added screen pos: 257 161
[ Service ] [2018-07-16T15:34:49] error: can't send profile snapshot, not yet received from cloud
[ Config  ] [2018-07-16T15:34:50] debug: current version is update to date
[ Service ] [2018-07-16T15:34:52] debug: starting core server process
[ Service ] [2018-07-16T15:34:52] error: failed to start server core process: Can't find screen with ID: -1
[ Config  ] [2018-07-16T15:34:52] warning: sharing from computer that is not connected

https://synergy-logs.symless.com/e5659cb7668a3232aa8b0473000f67d7/logs/8046-2018-07-16T15-36-03.log

 

Can anybody provide any feedback on this error, with possible work around solutions. An idea of what the actual problem is.

Link to post
Share on other sites

Can you please provide us with more information on your setup ?

(Linux is a vast thing, Distro name + version would maybe give someone the opportunity to help you)

Link to post
Share on other sites
Sean12312
$ uname -a
Linux scorpion 4.17.5-1-ARCH #1 SMP PREEMPT Sun Jul 8 17:27:31 UTC 2018 x86_64 GNU/Linux
$ cat /lib/systemd/system/synergy.service
[Unit]
Description=Synergy Service
After=network.target

[Service]
Type=simple
Restart=always
RestartSec=0
SyslogLevel=err
Environment=DISPLAY=:0
ExecStart=/usr/bin/synergy-service

[Install]
WantedBy=multi-user.target
$ cat Synergy.conf
[General]
profileId=8036
screenId=15921
userId=8046
userToken=QyqoIRVd1vPJAsx-HpH6IJbh

Sure, I am running Arch Linux. I've installed the latest Synergy 2 Beta 2 from the debian package (synergy_2.0.12.beta~b74+0b61673b_amd64.deb). Additionally I am running KDE window manager.

Link to post
Share on other sites
  • 3 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...