Jump to content

Windows service will not start


Recommended Posts

Last week my Synergy set-up died and I have been unable to resurrect it. The error message was simply

There was a problem connecting to the background service. Retry.

The key issue seems to be that the Windows service will not start on the server (Windows 10 Pro 64-bit). This problem originally occurred on 2.0.7, which led me to upgrade to 2.0.11.

I have completed a manual uninstall on Windows, including registry and directories, as per the “How to uninstall and reinstall” post. Then I rebooted. Then I reinstalled. The Windows synergy service is still unable to start. I have tried this at least three four times.

The problem seemed to occur after the Windows update: KB4103727.

I logged this with support a week ago (with logs etc), but after an initial response which blamed the Linux client, I have heard nothing. (I do not believe that this is anything to do with the Linux client, as the Windows service won't start even before I even install or configure the Linux client.)

The lack of contact, coupled with the fact that the service refuses to start even after removing all the previous registry and folders, would suggest that this is a fairly serious issue.

The logs have these errors (before configuration, or installation of client):

[ Service ] [2018-05-16T13:52:10] error: can't send profile snapshot, not yet received from cloud

[ Service ] [2018-05-16T13:52:16] debug: connecting websocket: pubsub1.cloud.symless.com:443
[ Service ] [2018-05-16T13:52:16] error: service failed: An invalid argument was supplied

If anyone has any suggestions or advice for me I would be grateful.

Thank you.


Link to comment
Share on other sites

13 minutes ago, GranPaSmurf said:

What Synergy version is on each box?

I wiped Synergy off both machines. I have re-installed 2.0.11 on the Windows machine (the server), but the service will not start, so I haven't got as far as reinstalling client yet.


Link to comment
Share on other sites

I have tried installing 2.0.7 and 2.0.4 - both refuse to run as "outdated". I appreciate the wish to have everyone running on the same version, but when things go wrong - it does limit the things we can try!

I have managed to scrounge version 1.8.5 off an old backup disk, installed - and they're working perfectly. What joy, what bliss.

I noticed during the install of 1.8.5 that it said that it couldn't work out my local IP, which is surprising given that it is a plain old IPv4 address. When I configured manually it offered both the IPv4 address and an address which isn't shown under

ipconfig /all

But I did manage to find a reference to it under Network Properties - Bluetooth networking, with status "disconnected" - could it be that this unused Bluetooth IP address is causing Synergy 2 to flip out?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...