Jump to content

Hello! ūüĎč

These forums are now archived (read only).

Join us on Discord.

Synergy 2 UNOFFICIAL Edition 2 Documentation


Recommended Posts


Synergy 2 UNOFFICIAL Edition 2 Documentation

Important: Before you do anything else, please open a support ticket.

Original Google Docs version (of this post)

Thank you for choosing Synergy 2 to improve the quality of your productivity. At the moment, this serves as a placeholder for Synergy 2 documentation until Symless decides it is appropriate to release documentation, which we assume to be when Synergy is in a more stable state and the initial bugs are ironed out.

Please note that this documentation is written by moderators with technical experience and help from Symless employees but is not considered ‚Äúofficial documentation‚ÄĚ.¬†As such,¬†if Symless decides to release official documentation, please refer to that documentation with the highest priority.

This documentation will be perpetually updated to match new issues that come up and to allow the solutions to adapt to new Synergy versions that are released. What follows will be a table of contents. Please try to find an issue that is, at the very least, similar to yours and find the solution. We will also include a list of general troubleshooting steps if your issue is not found here.

If those steps do not work and your issue is not found, go ahead and start a new post on the forums under¬†Self-support¬†and preface it with ‚Äú[DOCUMENTATION REQUEST]‚ÄĚ, and we will try to address it as soon as possible. Good luck, and if you need any more help, please contact the Synergy team at¬†[email protected]¬†or by using the contact link found on their homepage (www.symless.com/synergy). Thank you again.


Best wishes,

@Kelvin Tran


@jaap aarts

Moderators, Symless Forums



Synergy 2: The vision:


Synergy 2 is designed to be so simple to configure that anyone can use it.

Synergy 2.0 beta was released in July 2017, then as a stable version in November 2017. The intention of Synergy 2 is that when installed on multiple computers of a network, it runs invisibly and securely with no intervention needed by the end user.


The goal is a utility running in background that, when installed, auto-configures multiple computers operating on the same network to all use a single keyboard and mouse. This auto-configuration is accomplished by having each installation read the computer’s network configuration, send it to a cloud-server where it is matched to the configuration of the other computers of the network that also have Synergy 2 installed for a secure (SSL) connection.


Synergy’s History

The first version of Synergy was created on May 13, 2001, by Chris Schoeneman and worked with the X Window System only. Synergy now supportsWindows, macOS, Linux, and other Unix-like operating systems. Wikipedia.


Nick Bolton developed a fork of the then-dead Synergy in 2009 and popularized Synergy Pro, with frequent development improvements and updates.


Synergy 2.x.x (stable)

Synergy 2.0 was released as a stable product in November 2017. It is described by developer Nick Bolton:

There is, of course, a minority of users who believe that Synergy 2.0 is not finished. If you are part of this minority, then you need to wait for Synergy 2.1. For 2.1, we're planning to add a settings screen, offline activation, advanced settings, less reliance on the cloud, and various other features to cover edge-cases. So, in other words, 2.0 is for the vast majority who want an easy configuration experience, and 2.1 will be for the minority of users who want to get under the hood and tweak settings.   Read first: Synergy 2.0 is out of beta!


Forum> Synergy 2> Self-Support

Synergy  2.0 rapidly accumulated thousands of successful installations. However, in the modern world of computing, there is a huge mix of devices, operating systems and combinations. For some of these, Synergy 2.x.x does not function as a plug and play program.


The Self-Support forum is a gathering place for technically astute users who prefer to work through issues themselves, before contacting Support for help with a problem. A number of experienced Synergy users are volunteer moderators, helping, where possible, to guide users in resolving Synergy issues.


In the absence of official documentation from the developers of Synergy, we are publishing a few troubleshooting steps we have found useful.



Synergy2.x.x GUIk3yIdhdQ_2FrI7Ir7lm6vFV6RFzzGv0oPM8DxNV3


The GUI is intentionally sparse. You see the names of the computers in your network and the arrangement you’ve chosen. Rearrange the screens by selecting the screen and moving it with your mouse.


The white dot indicates the server. To change your selection of server, mouse over the desired screen display and right-click. As of version 2.06 the server selection will switch to whichever computer where you are using a keyboard. jO8oRqrcTHi9Ijc5ZqzrPwb0Tf7OuRHId56q86Zp


You can select the computer you wish to be server by right-clicking over that display.


The GUI supports opening the log by pressing the tilde key on your active keyboard. To send the log to support, right-click in the blue area of the GUI.

The GUI shows screens highlighted by displaying in green. This is supposed to give you an indication which computers are turned on and working properly. As of Version 2.06 this feature is not working reliably.


If, after you install Synergy on a network, you take a computer out of service or change the computer name, the GUI will continue to display the original device

until you install a new updated version of Synergy. Simply select the ‚Äėdead‚Äô screen and slide it aside and continue to use Synergy as usual.¬†See image here.



Troubleshooting Tips - LINKS


Error- There was a problem connecting to the background service. Retry

Error - ‚ÄúCould not open display‚Ä̬†

Synergy 2: How to send your logs

No mouse and keyboard input on Ubuntu 17.10 client

Logs show Wheel scroll warning lines like:

LOG LOCATIONS for Self-Debugging:

Manually Restarting Services

Quick Restart Synergy Core

Return to Synergy version 1

Synergy 2. XX Changelog

Uninstall Synergy   






Error - ‚ÄúCould not open display‚ÄĚ

Affected operating system(s):

  • (Arch) Linux


This means that you have a different setup that the standard for Linux. Usually the main display is given the ID of 0.0, but some systems might have different settings (arch Linux has lots of problems with this).

  1. To fix this, you should first open a terminal(on most desktop environments this is the windows/home/super button and then you can search for it) and enter the text below followed by a enter: 

            echo $DISPLAY


  1. This should give back a colon with a number behind it, in my case this is ‚Äú:1‚ÄĚ. Write this down or remember it.
  2. The next thing you have to do is check where the synergy.service file is located, for most systems it will be in¬†/etc/systemd/system/multi-user.target.wants, but this might vary. You can Google ‚Äúwhere are¬†systemd¬†service files <distribution name>‚ÄĚ or use the find command as follows:

    find / -name ‚Äúsynergy.service‚ÄĚ
  3. This will give you the location of the file. You can't just open this account, you need ‚Äúroot‚ÄĚ privileges to write to this file. You can use your favorite text editor to open it, use the following command and replace <text editor> with your favorite text editor and replace <location of the file> with the location you got from the ‚Äúfind‚ÄĚ command, Google, or the one provided by me.

    sudo <text editor> <location of the file>
  4. This will probably ask for you a password, enter this. If it says something about not being able to access something, or that you are not in the sudoers file(see below), you should ask your administrator to do this for you, from their account.

    <your username> is not in the sudoers file.   This incident will be reported.
  5. Now you should add this line before the line starting with ‚ÄúExecStart=...‚ÄĚ, replacing <display value> with the value you got from the first command.

    Environment=DISPLAY=<display value>
  6. Now save and close the file. You could either restart your computer, or type the following commands in the terminal:

sudo systemctl daemon-reload

sudo systemctl restart synergy

sudo systemctl status synergy // 

to check if it worked.

Other Solutions from user forum:

Ivan Tomika


  1. Regarding " Error - ‚ÄúCould not open display‚ÄĚ ", you don't need to edit .service file directly. In the matter of fact if you do that, it'll likely be overwritten on update. Instead, you can simply create override via:
  2. systemctl edit synergy.service
  3. and add:
  4. [Service]
  5. Environment=DISPLAY=:1
  6. You can find out your display by simply executing:
  7. echo $DISPLAY

Also, this issue is not Arch specific. Ubuntu for example also uses :1 as the DISPLAY 

Thanks- Synergy user Ivan Tomika, see post



Mike Hart

As an ArchLinux user, I was unable to get synergy to work with just this. I also had to define XAUTHORITY. To make this properly generic, I had to create my own service file.

The following file is: /etc/systemd/system/synergy@.service

Description=Synergy Service [multiuser fixed]



Once this file is in place, enable it like so

systemctl enable [email protected]

Where "myusername" is the name of your home directory.

Thanks- Synergy user Mike Hart, see post


How to restart the service from Linux command line:

as the admin.

net stop synergy

net start synergy

Thanks - Synergy Self-Support Forum Moderator  JDDoesIT , see post 



A shell script for Linux machines could look like the following:




if [[ "$(type -ft systemctl)" ]]; then

        systemctl restart synergy

elif [[ "$(type -ft service)" ]]; then

        service synergy restart

elif [[ -x /etc/init.d/synergy ]]; then

        /etc/init.d/synergy restart


        echo "Excuse me, how do you restart services in your system?" >&2

        exit 1


Just save it somewhere, give it execution permissions and you should be good to go.

Thanks - Synergy Self-Support Forum user eth0 , see post 





No mouse and keyboard input on Ubuntu 17.10 client

How to fix on Ubuntu 17.10:


Choose Ubuntu on Xorg when logging in, or change the config to disable wayland entirely.




(The next version of Ubuntu goes back to Xorg as default:




Scroll threshold incorrect


Logs show Wheel scroll warning lines like:


WARNING: Wheel scroll delta (28) smaller than threshold (120)


Github issue with fix: https://github.com/symless/synergy-core/issues/3657


LOG LOCATIONS for Self-Debugging:











  Error- There was a problem connecting to the background service. Retry 

Manually Restarting ServicesZrwcYLLOBEi82anivokLcd4otmESCXMwPx2tFOht

Sometimes on a new installation of Synergy or installation of an update version, Synergy does not make a solid connection with Synergy Service.


These instructions and/or screenshots may vary from your unique setup.



  1. On Windows 10, press the Windows Key + R, then type ‚Äúservices.msc‚ÄĚ.
  1. Alternately, from the Start menu, type ‚Äúrun‚ÄĚ then ‚Äúservices.msc.‚ÄĚ Older Windows systems, type ‚Äúrun‚ÄĚ then ‚Äúmsconfig.‚ÄĚ The System Configuration pop-up opens. Select the tab ‚ÄúServices‚ÄĚ and scroll down to ‚ÄúSynergy.‚ÄĚb3ohnsEiGeEWaSWLt-KlaHGxMYhFZkV1VV0MSX6S
  2. Select ‚ÄúStop the service.‚ÄĚ ¬†When the service has completely stopped, select ‚ÄúStart the service.‚ÄĚ

This should allow Synergy to start normally. Sometimes this procedure needs to be repeated several times before there is a solid connection.





MAC Open both the Terminal app and the Activity Monitor (found in Applications > Utilities)

  1. Paste and run: 
    launchctl unload Library/LaunchAgents/com.symless.synergy.synergy-service.plist
  2. Paste and run: 
    sudo killall synergy-core
  3. Ignore the message, "No matching processes..."
  4. Paste and run: 
    launchctl load /Library/LaunchAgents/com.symless.synergy.synergy-service.plist
  5. Go back to Synergy, right-click on a computer and select "Share from"iVI-NXjqZl92IyGMqH1paBUgi860F29XhOXMWBev


  1. If Synergy is closed, paste and run: 
    open -n /Applications/Synergy.app
  2. If the problem is not resolved, repeat all steps on every computer



  1. Open the Terminal program
  2. Run:
    sudo systemctl restart synergy
  3. Go back to Synergy, right-click on a computer and select 
    "Share from" 
  4. enter
  5. If the problem is not resolved, repeat all steps on every computert710Ikym6lPqCvOWKXGs4pQx4ADxxEmt3wKCQtB_


Quick Restart Synergy Core

How to restart all the Synergy cores - On the Synergy UI of any machine:


1. move any computer to another location

2. move it back to its original place

This will restart the core on both machines


Here's how to send us your logs

  1. Right-click on the blue background and click Send log.
  2. Wait for the log to upload, then click View log.
  3. Paste the link into a new thread on this forum.
  4. Please do this for all of your computers.
  5. Let us know which log is for which computer.


Return to Synergy version 1

If a user purchased a 2.0 license Symless will grant downgrade rights if they contact:

[email protected]

to revert to version 1


Uninstall Synergy




Uninstall Synergy using Add or remove programs (or Apps & features).




First, open the Terminal app and run this command:


launchctl unload /Library/LaunchAgents/com.symless.synergy.synergy-service.plist


Next, delete the Synergy app from the Applications directory.


Finally, reboot your Mac which will remove the helper tool.




First, Remove the Synergy package using your package manager.

Finally, run these commands to remove your settings:

rm -rf ~/.config/Symless/

rm -rf ~/.synergy/

Alternative Linux uninstall:

type this in the terminal

sudo apt-get purge <packagename>

the packagename is probably "synergy"


Published by¬†Google Drive‚ÄďReport Abuse‚ÄďUpdated automatically every 5 minutes









Link to comment
Share on other sites

  • Nick Bolton unfeatured this topic
  • Nick Bolton unpinned this topic
  • 1 year later...
  • 5 months later...
On 12/06/2019 at 4:45 AM, Brobo said:

I only get the message " You're all set! Please return to Synergy ". Both on my Mac and Windows

Still getting this same issue. I've tried everything..

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...