Jump to content

Raspberry PI - ARM support


R.W

Recommended Posts

  • 1 month later...
On 1/31/2018 at 12:10 PM, Nick Bolton said:

We plan on adding support in 2.1 which is due in about 6 months.

Will that support include basic universal armhf binaries for all arm-based systems? Besides the Raspberry PI there also exist the fairly popular Odroid lineup which run on armhf as well. The last version to exist for any Odroid ported distros is 1.8 or 1.6 in the case of Ubuntu 16.

Link to comment
Share on other sites

  • 4 weeks later...
On 3/18/2018 at 6:38 PM, Nick Bolton said:

Sure, I don't see why not.

The release of today does not work on Ubuntu Mate on odroid, dependency issue libqt5core5a is version 5.5.1 with 5.7.0 needed.

Link to comment
Share on other sites

dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.7.0); however:
  Version of libqt5core5a:armhf on system is 5.5.1+dfsg-16ubuntu7.5.
 synergy depends on libqt5svg5 (>= 5.6.0~beta); however:
  Version of libqt5svg5:armhf on system is 5.5.1-2build1.
 synergy depends on libssl1.1 (>= 1.1.0); however:
  Package libssl1.1 is not installed.
 synergy depends on libstdc++6 (>= 6); however:
  Version of libstdc++6:armhf on system is 5.4.0-6ubuntu1~16.04.9.
 synergy depends on qml-module-qtquick-controls (>= 5.5.0); however:
  Package qml-module-qtquick-controls is not installed.
 synergy depends on qml-module-qtquick-layouts (>= 5.5.0); however:
  Package qml-module-qtquick-layouts is not installed.
 synergy depends on qml-module-qtquick-dialogs (>= 5.5.0); however:
  Package qml-module-qtquick-dialogs is not installed.
 synergy depends on qml-module-qtquick2 (>= 5.5.0); however:
  Package qml-module-qtquick2 is not installed.

 

Link to comment
Share on other sites

  • 2 weeks later...
On 4/11/2018 at 10:51 AM, Nick Bolton said:

Looks like we need some more builds!

2.0.10 build I get this:

 

dpkg: dependency problems prevent configuration of synergy:
 synergy depends on libqt5core5a (>= 5.7.0); however:
  Version of libqt5core5a:armhf on system is 5.5.1+dfsg-16ubuntu7.5.
 synergy depends on libqt5svg5 (>= 5.6.0~beta); however:
  Version of libqt5svg5:armhf on system is 5.5.1-2build1.
 synergy depends on libssl1.1 (>= 1.1.0); however:
  Package libssl1.1 is not installed.
 synergy depends on libstdc++6 (>= 6); however:
  Version of libstdc++6:armhf on system is 5.4.0-6ubuntu1~16.04.9.

 

This is because either depending specifically to odroids builds or generally ARMHF is always behind on libs so using the latest from x86 equivalent will result in issues. Two ways, either port these libs yourself and provide them along with the builds or write them out/older versions.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...