Jump to content

Problem with Hyper-V Virtual Network Interface


Ray Barbieri

Recommended Posts

I have to disable all the "default switch" instances in network and sharing center.  There's been lots of posts over the year during the Beta and I can't tell if this issue has been addressed.  Essentially, from the logs, it is clear that Synergy tries to connect using the the IP of the Hyper-V switch: "vEthernet (Default Switch)" instead of the "vEthernet (External)". My local network is the 192. subnet but I see lots of connection attempts in the 172. subnet which is the address of my Hyper-V Switch.

Both windows 10 systems have Hyper-V installed and I've seen these problems on both systems.  There's 10 attempts before it eventually giving up. 

From the logs, until I disable the "default switch" in network sharing, it retries that address over and over again - despite me restarting the service manually.  Furthermore, it did not detect that the 192 subnet was alive and well during this period.  https://synergy-logs.symless.com/3d3c92a38e6c90b3f91273e3db783e1d/logs/2270-2017-11-24T10-32-46.log

Eventually, after disabling they hyper-v network, it connected fine.  HOWEVER, on 192.168.168.25, the app shows that neither system is "green" but as I type, I'm on that system with the mouse connected to my other system (192.168.168.26).  https://synergy-logs.symless.com/3d3c92a38e6c90b3f91273e3db783e1d/logs/2270-2017-11-24T10-42-35.log

Seems the algorithm for detecting which network the other synergy clients are on is still a work in progress. This has been consistently happening to me from the start of the Beta.

I'm posting here as I don't see any other posts in this forum on this topic.

 

Link to comment
Share on other sites

  • Kelvin Tran changed the title to Problem with Hyper-V Virtual Network Interface
  • 1 year later...
Ryan Willis

This is still a problem. I downgraded from Synergy 2 due to instability and Synergy 1 is still connecting via the hyper-v adapter rather than the active wifi connection. Hoping to trick it, I renamed the wifi adapter so it is listed before the vEthernet but no dice, haha.

We need to a way to select a preferred adapter..

Link to comment
Share on other sites

Kelvin Tran
On 7/12/2019 at 12:28 PM, Ryan Willis said:

This is still a problem. I downgraded from Synergy 2 due to instability and Synergy 1 is still connecting via the hyper-v adapter rather than the active wifi connection. Hoping to trick it, I renamed the wifi adapter so it is listed before the vEthernet but no dice, haha.

We need to a way to select a preferred adapter..

Hi there!

I'm sorry you're still having this issue and that no one responded to your post dated 2017. I haven't been on the Synergy project for a good while, so I implore you to please excuse my rustiness on the Synergy material.

In Synergy 1, there should be a way that you can select network adapter affinity for the application. Better yet, you can set a static IP for the server on your clients. As far as I'm aware, on Synergy 1, it's a client-to-server connection topology. So, theoretically, if you manually force all client(s) to connect to the server IP (which, presumably, would be on the 192 subnet), it should be forced to use your external network adapter since a route wouldn't exist for the other subnet on your default switch.

Try it and let me know how it works out for you. Again, I apologize for the lack of activity on this post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...