Jump to content
Get SynergyOpen a support ticket

wayland support


josegalvez

Recommended Posts

NorthWestUser

For those interested, I found this repo with a Synergy/Barrier client for Wayland https://github.com/r-c-f/waynergy

It is only a client and based on the open source uSynergy from Symless, and it took me a bit of work to map the keys, but I got it working on my Wayland guests with Synergy server running on macOS. 

Link to post
Share on other sites
  • Replies 69
  • Created
  • Last Reply

Top Posters In This Topic

  • TrentC

    12

  • josegalvez

    4

  • Brian Hechinger

    4

  • Ninbura

    4

Top Posters In This Topic

Popular Posts

A message to the developers: I saw in your issues page where the lack complaints from licensed users (as opposed to Github users) makes this look like a low priority issue to you. As a licensed user,

not sure when wayland support is planned, but linux is moving pretty fast in that direction. Doesn't effect me at the moment, but I'm sure my next upgrade will see wayland on my computer either alone

Hi here! Visiting from the Wayland support for Linux client and server GitHub issue. Just want to voice in my request for this feature too so that Synergy can support most of the recent releases to th

Posted Images

On 1/24/2022 at 1:41 AM, metamemelord said:

Not working on Fedora 34 on Wayland. Is there an official word/timeline when Synergy will support Wayland?

As it has been mentioned quite a few times, "in the next major version."

Link to post
Share on other sites
On 1/24/2022 at 1:41 AM, metamemelord said:

Not working on Fedora 34 on Wayland. Is there an official word/timeline when Synergy will support Wayland?

As it has been mentioned quite a few times, "in the next major version."

 

Maybe the "alpha" forum they are mentioning if it is already supporting Wayland, or not

Link to post
Share on other sites
On 1/24/2022 at 1:41 AM, metamemelord said:

Not working on Fedora 34 on Wayland. Is there an official word/timeline when Synergy will support Wayland?

As it has been mentioned quite a few times, "in the next major version."

 

Maybe the "alpha" forum they are mentioning if it is already supporting Wayland, or not

Link to post
Share on other sites
lemonjello1

FYI in addition to Fedora and RHEL, the upcoming Ubuntu 22.04 LTS is also now switching to Wayland.

  • Like 1
  • Sad 1
Link to post
Share on other sites
delmarc

I had to switch over to Wayland due to a displayport issue for my multi screen setup... X would have a low FPS in Xorg but under Wayland everything works as expected... Multiple year user of synergy and would like not to be forced to use other products... its always just worked... now just stuck... please find some solution here as its a product waiting to die otherwise...

Link to post
Share on other sites
  • 2 months later...
Jake Harr

Just bumping this. I'm starting to look into upgrading to Ubuntu 22.04 and what that entails on the machine that runs my Synergy server.

I'm sure that Wayland support is a huge effort. Is there anywhere we can get updates on development?

Link to post
Share on other sites
TrentC

Good luck on any updates. They been working on version 3 since about 2018, and barely an Alpha version?

He should probably just put it all back in open source. Back then it seemed to make better progress in development time. Can't stay in business by taking 10 years to release a new version which is compatible with newer operating systems.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...
Steve3PO

I am a paid subscriber for Synergy version 1 and 2.

Please add Wayland Support.  Come on!

  • Like 1
Link to post
Share on other sites
TrentC

I am not even sure they are in business anymore. It does not take several years to come out with a release.

  • Like 1
Link to post
Share on other sites
redzebra
Posted (edited)

I upgraded to Ubuntu 22.04 today and can't use Synergy anymore 😢

Edit: I'm a Synergy Pro user! Please providing Wayland support

Edited by redzebra
  • Like 1
Link to post
Share on other sites
suprkain
1 minute ago, redzebra said:

I upgraded to Ubuntu 22.04 today and can't use Synergy anymore 😢

It has to do with an outdated dependency. 
 

Supposedly it'll be fixed whenever the next update comes out.  No ETA has been provided unfortunately.

  • Like 1
  • Sad 1
Link to post
Share on other sites
UnixOutlaw

Fresh install of Ubuntu 22.04 last night - can't install synergy, not even with --fix-missing or install -f...  

Ended up here - same issue libssl library missing as for Mint user trying to get MongoDB installed

https://askubuntu.com/questions/1403619/mongodb-install-fails-on-ubuntu-22-04-depends-on-libssl1-1-but-it-is-not-insta

So I did this : 

echo "deb http://security.ubuntu.com/ubuntu impish-security main" | sudo tee /etc/apt/sources.list.d/impish-security.list

sudo apt-get update
sudo apt-get install libssl1.1

And that fixed it for me - can now install (the package for Ubuntu 21.04) with dpkg - thanks so much Symless for all your support - Ubuntu 22.04 is only like SIX WEEKS old and you don't have an installer package for that LTS release?  Your package for Ubuntu 21.04 DOES NOT WORK!

I guess we can expect a fix for our "pro" product, from this vendor (Symless?  More like Gormless) around the same time as Wayland which they only like promised was on their radar in 2014!

I'm not crazy about this fix, 'cause I HATE adding non LTS repos into my LTS system!  FIX THIS SYMLESS - and SOON!

Link to post
Share on other sites
suprkain
5 hours ago, UnixOutlaw said:

Fresh install of Ubuntu 22.04 last night - can't install synergy, not even with --fix-missing or install -f...  

Ended up here - same issue libssl library missing as for Mint user trying to get MongoDB installed

https://askubuntu.com/questions/1403619/mongodb-install-fails-on-ubuntu-22-04-depends-on-libssl1-1-but-it-is-not-insta

So I did this : 

echo "deb http://security.ubuntu.com/ubuntu impish-security main" | sudo tee /etc/apt/sources.list.d/impish-security.list

sudo apt-get update
sudo apt-get install libssl1.1

And that fixed it for me - can now install (the package for Ubuntu 21.04) with dpkg - thanks so much Symless for all your support - Ubuntu 22.04 is only like SIX WEEKS old and you don't have an installer package for that LTS release?  Your package for Ubuntu 21.04 DOES NOT WORK!

I guess we can expect a fix for our "pro" product, from this vendor (Symless?  More like Gormless) around the same time as Wayland which they only like promised was on their radar in 2014!

I'm not crazy about this fix, 'cause I HATE adding non LTS repos into my LTS system!  FIX THIS SYMLESS - and SOON!

The fix is supposed to be in the next update, version 1.14.4.  It should be out early next week.

Link to post
Share on other sites
UnixOutlaw
27 minutes ago, suprkain said:

The fix is supposed to be in the next update, version 1.14.4.  It should be out early next week.

Or next decade?  Century?  They don't have a good track record...    Wayland was "on the radar" in 2014?  

I mean who even asked for the following

  1. Leave TLS on in server and client by default  ???
  2. Change "X" (title bar window control widget) exit behaviour from "exit to system tray or top bar" to "let's exit this application and kill it"? 

It's starting to feel like a backyard "single guy" operation, rather than the "enterprise" App I bought in 2018... 

I'm just about ready to cutover from this substandard piece of crap to a hardware solution...

 

Link to post
Share on other sites
TrentC

This app was open source some years ago. He was complaining nobody was donating so he closed the source then started selling it. The ironic thing is, it was making more progress as an open source project than closed source.

Link to post
Share on other sites
  • 3 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...