Jump to content
Get SynergyOpen a support ticket

Does Synergy prevent monitor from going to sleep?


JohnCLeBlanc

Recommended Posts

Steve, thanks for getting back to me!

Yeah its a shame.  I have three PC's each with separate monitors.  The central one has the keyboard and mouse (server) and the others (left and right) have monitors only.  All three are Windows 10 rel1 809.

The central's power management works fine.  The two clients not at all. 

Do the folk from Synergy do updates?  Do I need to monitor a site and see when patches/updates/new versions are released?

Link to post
Share on other sites
  • 2 weeks later...
  • Replies 60
  • Created
  • Last Reply

Top Posters In This Topic

  • Theo

    7

  • Steve Baker

    6

  • ichigeki

    5

  • hiphopbros

    5

Top Posters In This Topic

Popular Posts

Had exactly the same problem on all clients, so I did powercfg /REQUESTSOVERRIDE process synergy-core.exe display system from elevated command prompt on every client machine and it took care of

Ok, I uninstalled Synergy 2 on all my machines and replaced with Synergy 1, sleep mode working as espected, problem solved !   

This is a real shame for this thread to even exist. First of all, this program doesn't have a trial, but does have a money back guarantee, so one would expect it to "just work" out of the box.

I installed the "Stable" version rather than the "Beta" version because I don't need anything fancy. I only have 2 PCs, both Windows 10. One has a mouse and keyboard, the other monitor only. Basic mouse, keyboard and clipboard functionality needed.

From the time I installed it I thought I had found the best option out there. Then I noticed my second monitor doesn't sleep anymore and neither does the PC.

This isn't a lack of function. This is functionality that breaks already existing OS functionality. "Bug" barely begins to describe this behavior. And to know that it's been happening to others for years and is still a part of the "Stable" version of a program is a bit sad.

I am not going to run some registry hack to get a program to work that I paid for.

Even Mouse Without Borders didn't have this problem. Neither did Multiplicity.

Link to post
Share on other sites
Steve Baker

Well, I guess it depends on how much the functionality is worth to you.   For me, personally, the benefits of Synergy over the other choices by far outweigh the pain of the bug.

Neither Multiplicity nor Mouse-without-Borders are cross-platform - they are strictly Windows-only.

Synergy lets you share a mouse and keyboard AND do copy/paste across two computers that are running entirely different operating systems!  I need to share between Linux and Windows...so both of the alternatives that you suggest are 100% useless to me.

The annoying failure-to-sleep bug - is just that: "annoying" - my LED monitors don't use that much power - I can always just turn them off at the end of the day, and the small savings with having them sleep when I'm actively working isn't that great - but if you used laptops on battery power, that would be horrible.

So for *ME* I'd very much like to see the bug fixed - but it isn't going to send me running to another keyboard/mouse sharing app.

However, it's good that some people are prepared to skip Synergy because of this because it applies pressure to Symless to fix the bug.

 

Link to post
Share on other sites
Steve Baker

Also, you didn't mention "ShareMouse" - which is Windows/Mac cross-platform - but (bizarrely) doesn't support Linux - "KaVoom" and "Input Director" (both also Windows-only).

 

Link to post
Share on other sites

I found another forum with what seems to be a fix within the program itself.

Under Configure Server -> Advanced server settings,

I unchecked the "Synchronize screen savers" checkbox.

Now my secondary monitor goes to sleep.

Link to post
Share on other sites
Fabian Santiago

So, i'm using a win 10 pro v1809 PC as my synergy server with an ubuntu 18.10 desktop as the client running gnome 3.30.1 as my desktop environment and both are running current synergy v1. display blanking does seem to work for me. 

unrelated to this issue (or maybe it is?), if i take control of my client's desktop and then press windows key + L to lock the desktop, it also locks my server's screen. but normally there is proper separation based on my mouse's location. 

Link to post
Share on other sites
  • 3 months later...
On 2/21/2019 at 9:09 AM, WallyJ said:

Under Configure Server -> Advanced server settings,

I unchecked the "Synchronize screen savers" checkbox.

Thank you so much!! Worked for me :)

Windows 10 primary, kubuntu 18.10 secondary

Link to post
Share on other sites
  • 1 month later...
David Henry

The original command was

 

Quote

powercfg /REQUESTSOVERRIDE process synergy-core.exe display system

and it wasn't working. So I opened taskman and found Synergy daemon and process. Opened the file location and saw that the names were different.

So I ran

Quote

powercfg /REQUESTSOVERRIDE process synergyc.exe display system

and

Quote

powercfg /REQUESTSOVERRIDE process synergyd.exe display system

Because I don't know which is what on both client computers and it works fine. 

3 computers with 10 monitors with all sleeping.

 

Link to post
Share on other sites
  • 2 months later...
Jay Maynard

This is evidently still a thing.

My server computer is a Mac Pro running macOS Catalina, just installed yesterday, thought he behavior long predates that install. My client computer is another Mac Pro running Pop!_OS 19.04 (an Ubuntu derivative). Both systems are running 1.10 stable (the server 1.10.0, the client 1.10.1). Per the suggestion above, I turned off the synchronize screen savers setting. No help.

The screen on my macOS machine powers off fine. The screen on the Pop!_OS machine does not. It does go black, but stays powered up. If I kill the synergyc program, then the screen powers off.

Is there some way to tell the GNOME Shell to ignore Synergy? Or to tell Synergy to quit doing whatever it is doing? Killing the client and then restarting it is a pain.

Link to post
Share on other sites
  • 1 year later...
Kobld
On 10/13/2019 at 6:42 AM, Jay Maynard said:

This is evidently still a thing.

My server computer is a Mac Pro running macOS Catalina, just installed yesterday, thought he behavior long predates that install. My client computer is another Mac Pro running Pop!_OS 19.04 (an Ubuntu derivative). Both systems are running 1.10 stable (the server 1.10.0, the client 1.10.1). Per the suggestion above, I turned off the synchronize screen savers setting. No help.

The screen on my macOS machine powers off fine. The screen on the Pop!_OS machine does not. It does go black, but stays powered up. If I kill the synergyc program, then the screen powers off.

Is there some way to tell the GNOME Shell to ignore Synergy? Or to tell Synergy to quit doing whatever it is doing? Killing the client and then restarting it is a pain.

I don't know the syntax on a mac, but you wouldn't be searching for "GNOME shell". Mac uses BASH by default... 

Either way, it appears there's a command called "caffeinate". There must be something similar on those god awful apple devices. https://apple.stackexchange.com/questions/62558/how-to-prevent-mac-sleep-from-command-line

 

If that fails, you could always ask the question on the apple stack exchange. 

Edited by Kobld
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...