Jump to content

Start Synergy 2 on startup (GDM + KDE)


colwellkr

Recommended Posts

Under Synergy 1 I was able to start synergy's client automatically at started by editing /etc/gdm/Init/Default as suggested here (https://help.ubuntu.com/community/SynergyHowto#On_the_Client-1). However, as synergyc no longer exists in Synergy 2 and Synergy 2 seems very dependent on its gui at startup, I am at a loss as to how get it to start automatically with my system. 

Once logged in I was able to autostart Synergy 1 using the same synergyc command that was used for GDM.

Any suggestions as to how I get back to launching synergy on boot/login?

Couple of side questions:
Does synergy 2 have SSL enabled? I can't find any information in the logs and there seem to be no configuration options anymore.
Any idea why my synergy jitters a lot when transitioning from Windows (server) to Linux (client)?

Thank you very much!

Link to comment
Share on other sites

I will be interested to see answers from other forum people. 

Just with the most recent version, 2.01-stable, I noticed Synergy 2 autostarts on all 3 of my machines. 

Win10 - Kubuntu 17.04 and Win 7 (32 bit)

What experiences are the rest of the forum having?

Link to comment
Share on other sites

58 minutes ago, KringleKrebs said:

Just with the most recent version, 2.01-stable, I noticed Synergy 2 autostarts on all 3 of my machines. 

Thanks for the response, I hadn't actually tried rebooting since I upgraded to 2.0.1-stable, but I just confirmed that it is not auto starting on my Centos 7 box and it isn't listed in the startup items on my Windows 10 box either. There could be some other things interfering with normal startup processes though as both machines are joined to my work's AD domain.

Link to comment
Share on other sites

If you are using systemd, the core process should already be enabled.

Have not tested this, but try changing out your edits from synergyc to synergy-config (which is a poor name for the gui, but alas)

Link to comment
Share on other sites

  • 4 weeks later...
On 11/24/2017 at 8:20 PM, Pigeon said:

Same issue here. I use lightdm, but things should be close enough among kdm/gdm/etc.

I had a quick look, what I've found so far is with Synergy 2, synergy-service is runautomatically and it runs synergy-core, which is good. However, at lightdm/gdm, synergy-core can't connect to Xorg due to permission issue.

From Synergy2 log file I can see things like:


[2017-11-25T12:15:01] NOTE: stopped client
[2017-11-25T12:15:05] DEBUG: XOpenDisplay(":0")
[2017-11-25T12:15:05] WARNING: secondary screen unavailable: unable to open screen
[2017-11-25T12:15:05] DEBUG: retry in 60 seconds
[2017-11-25T12:15:05] DEBUG: event queue is ready
[2017-11-25T12:15:09] NOTE: stopped client

Xorg is run by lightdm as:


/usr/lib/xorg/Xorg -ac :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Note the -auth option. So what I end up doing is settings XAUTHORITY=/var/run/lightdm/root/:0 to the synergy service, which will then get passed along when it runs synergy-core:


[Service]
Type=simple
Restart=always
RestartSec=0
SyslogLevel=err
Environment="XAUTHORITY=/var/run/lightdm/root/:0"
ExecStart=/usr/bin/synergy-service

I added in both /usr/lib/systemd/system/synergy.service and /lib/systemd/system/synergy.service, as I'm actually not sure which one is used.

That auth file is only readable by root, and when synergy-service runs synergy-core it runs with --run-as-uid (which is a good practice, but I have to break this unfortunately). So I also changed /var/lib/synergy/synergy-user.cfg and changed uid="1000" to uid="". Remember to stop synergy service before changing this file ("service synergy stop"). After this, synergy-core will be run as root.

This is definitely a workaround. Not sure what's the proper fix for this. Maybe @Nick Bolton can comment on this?

 

How did you get it install on linux??? All I get is a error message and a smart ass response from tech support about it

Link to comment
Share on other sites

47 minutes ago, jeffl said:

How did you get it install on linux??? All I get is a error message and a smart ass response from tech support about it

That's a totally separate topic. They provide packages for Linux.

In other news, I ended up downgrading to 1.8 because 2 just stopped working. Client and server refused to communicate and there were no diagnostics or configurations in sight.

Link to comment
Share on other sites

On 11/25/2017 at 3:20 AM, Pigeon said:

Same issue here. I use lightdm, but things should be close enough among kdm/gdm/etc.

I had a quick look, what I've found so far is with Synergy 2, synergy-service is runautomatically and it runs synergy-core, which is good. However, at lightdm/gdm, synergy-core can't connect to Xorg due to permission issue.

From Synergy2 log file I can see things like:


[2017-11-25T12:15:01] NOTE: stopped client
[2017-11-25T12:15:05] DEBUG: XOpenDisplay(":0")
[2017-11-25T12:15:05] WARNING: secondary screen unavailable: unable to open screen
[2017-11-25T12:15:05] DEBUG: retry in 60 seconds
[2017-11-25T12:15:05] DEBUG: event queue is ready
[2017-11-25T12:15:09] NOTE: stopped client

Xorg is run by lightdm as:


/usr/lib/xorg/Xorg -ac :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Note the -auth option. So what I end up doing is settings XAUTHORITY=/var/run/lightdm/root/:0 to the synergy service, which will then get passed along when it runs synergy-core:


[Service]
Type=simple
Restart=always
RestartSec=0
SyslogLevel=err
Environment="XAUTHORITY=/var/run/lightdm/root/:0"
ExecStart=/usr/bin/synergy-service

I added in both /usr/lib/systemd/system/synergy.service and /lib/systemd/system/synergy.service, as I'm actually not sure which one is used.

That auth file is only readable by root, and when synergy-service runs synergy-core it runs with --run-as-uid (which is a good practice, but I have to break this unfortunately). So I also changed /var/lib/synergy/synergy-user.cfg and changed uid="1000" to uid="". Remember to stop synergy service before changing this file ("service synergy stop"). After this, synergy-core will be run as root.

This is definitely a workaround. Not sure what's the proper fix for this. Maybe @Nick Bolton can comment on this?

 

I am having the same problem, I thought they'd fix it in 2.1.

can you tell me what your Xdisplay is("echo $DISPLAY" in the terminal) to confirm this?

Link to comment
Share on other sites

On 12/20/2017 at 9:42 PM, jeffl said:

How did you get it install on linux??? All I get is a error message and a smart ass response from tech support about it

Have you opened a new topic about this? and can you send a link to it?

If not, you should open one, and send a link to it.

 

Link to comment
Share on other sites

  • 2 months later...

Damm, I bought this version 2 and I use Slackware (No systemd): You guys should have a generic linux compatible version, like the older version.
 

Link to comment
Share on other sites

GranPaSmurf

If I understand correctly, the developers are focusing on improving the Linux version for the next update.

 

Link to comment
Share on other sites

Hello. It appears I am in the same boat.

I have downloaded Synergy 2.0.6 Pro and am unable to utilize it on my Linux system (Gentoo) as I use OpenRC instead of systemd. Since I am not planning on switching to systemd, I guess I'll have to wait for a Synergy update that is "init system agnostic". A generic daemon / service as stated above would definitely work and would surely not be complicated to implement.

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...