Jump to content
Get SynergyOpen a support ticket

Mouse Cursor appearing at the middle of the screen?


HelloThere

Recommended Posts

Hey all, 

Maybe I found a solution, but maybe not the exact same problem though...

I bought Synergy basic this past month, and I was super happy, it was working flawlessly with 2 computers, 3 monitors. I was all joy, even bought a pro one to my daughter (last year of high-school, super multitasking with a laptop and macmini to complete this pandemia-school-year)

But suddenly I started to have this problem:  the mouse "ghost" appearing in the MacOS BigSur server (iMac), and I had what appeared to be a big delay in movement (needed to push the mouse across half mouse pad in the direction of the "jump" from server to client and vice versa (Pop_OS-Ubuntu 21.04 laptop (old 2012 macbook pro) to an iMac with BigSur). Really annoying...

Searching the mighty sea of Google answers, between synergy, barrier and share-mouse forums, I found a collection of answers that solved the problem to me. My Synergy version is 1.14.0-stable-67d824b8

First, I had the dock of MacOS moved to the left side, and to jump computers the mouse crossed the dock, and the ghost pointer appeared. The dock broke the "hide mouse thing". --> solution: moved the dock to bottom and now the mouse keeps hidden when changing computers.

Second, one thing that preceded the "break" in the system was, I took the laptop with me on an errand, so disconnecting from the middle monitor (my setup uses a HDMI switch to jump the middle monitor from laptop to iMac, but usually the middle monitor stays with the iMac - the server). So after I reconnected physically the monitor, the "lag" on the mouse travel (half mousepad) to appear in the other computer screen was consistent with what would be the needed mouse movement to go half screen of the iMac (server), from the ghost mouse in the center of the screen to the edge. --> solution: I just needed to manually disconnect (stop) the synergy client, circle the HDMI switch states, and restart (connect) the client to the server. 

Voila!!!

I hope this can help anyone. The ghost pointer in MacOS and the extra mouse travel where terrible.

best regards

joko

 

 

setup.jpeg

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...