Jump to content

Hello! 👋

Our forums have moved to: discourse.symless.com

These forums are now archived (read only).


Recommended Posts

Alan Harris
Install on my Linux Mint box was OK. Install to Win7 32 bit progressed OK (setup as client) but no connection to server (Linux box). In the log file and shown in interface it says there was an "error writing to a file already existing". Not a helpful message - which file is it complaining about??? Supposed the message was about a config file so closed everything and stopped the Synergy service. Renamed all svg and cfg files then restarted the synergy service and got the same error message. Rebooted PC and got the same message. Uninstalled Synergy on Win7 and re-installed - got same error message. Uninstalled Synergy on Win7 and searched all of Registry for any mention of synergy and deleted all entry types. Reinstalled Synergy as client and now performs as expected. The registry gave no indication of where config files are stored though when I requested to store the configuration the system opened at the Windows\System32 directory but there was no file in there for synergy prior to me uninstalling everything. Anyone know: 1. If it can be documented which config files are created and used in a vanilla install? 2. Even if parts of registry are cleared down as part of an upgrade on windows, is the default config file placement just a memory file and not a real file? 3. Am I mistaken on what the error message is trying to tell me? Regards Al
Link to post
Share on other sites
  • 7 months later...
1. By default, config files are generated every time Synergy is restarted by the GUI, and placed in the temp file location appropriate to each OS. On Windows, this means the user's personal temp folder, c:\users\[username]\Local Settings\Temp, or %temp% for short. The file will be named something like qt_temp.[random letters and numbers]. On Mac, it goes in something like /var/folders/_q/[random letters and numbers]/T/Synergy.[random letters and numbers] or similar. On Linux, it goes in /tmp. 2. It's a real file, which the GUI generates on each run based on the settings saved in the registry. 3. The error is not about the config file at all. The English version is "Cannot create a file when that file already exists" - it's a bug having to do with communicating with the system service in Windows. I don't know the underlying cause. See: https://github.com/synergy/synergy/issues/3752
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...